I recently Bought a new laptop which is Asus N501vw Middle East Version or UX501vw!

It has original Windows 10 Installed on it. I wanted to dual boot ubuntu with Windows to have them both because I didn't want to lose original windows.

I started installing it on UEFI mode (and I followed Tutorials and did all the things in the Bios setting, etc.)

I was able to boot my flash drive in UEFI mode, but every time I tried to boot into live session (or even Installation) I wasn't able to do so. It would stick on the splash Screen (I tried different Verison of Ubuntu 16.04, 15.10 and even Elementary OS 0.3, 0.4).

All of them have the same problem! I figured out that it might have some problems with my Nvidia Graphics Drive So I booted using "nomodeset" and "xforcevesa" boot flags and it booted successfully! This time, my 4K screen resolution can't be reduced, graphics are awful, everything's small and unreadable, my screen has these black gaps around it that I can't see OS GUI and most of the times my CPU fan Starts to run at the highest speed possible that I can hear it out loud and I panic and force restart my laptop because it won't stop! I barely have any process open!

I do need Linux as my main operating system! but I really don't know how to fix these!

I think it's a problem with my Intel HD graphics and Nvidia!

I would appreciate if you could help me with this! I currently have Elementary Os 0.4 Loki installed! Windows File system sucks, I do hate everything about windows but I have no choice but to use it and I'm dying here!


After a lot of Searching, I finally came up with the solution. So here it is:


All I had to do was to install elementary (Or I assume any other ubuntu derived Linux distro) with nouveau.modeset=0 boot flag and remove the quite and splash flags.

Also, I had to boot one more time using the exact same options to elementary OS to prevent what was happening, which I guess, it has something to do with Optimus or Nvidia Graphics.

Once You booted to elementary just use Nvidia Graphics Driver from Aditional Drivers and restart and it won't happen again! It will boot like a charm from now on!

Fan Speed Problem:

Let's not forget to mention that once I switched to using Intel HD Graphics using Nvidia X Server Settings App, every time I logged in my laptop fan started to work at the maximum speed. So I managed to solve that with upgrading to the latest stable Linux Kernel (4.8.1 by the time I send this).

Here's how you can upgrade kernel to 4.8.1:

$ wget http://in4serv.com.br/backup/kernel-4.8.1-stable
$ sudo chmod +x kernel-4.8.1-stable
$ ./kernel-4.8.1-stable

Why I switched to Intel HD Graphics:

The reason I switched to Intel graphics was that every time I tried to watch something on youtube maybe in full HD, I used to see glitches in videos (and also on VLC). Pantheon Desktop also used to get weird with displaying background and animations sometimes! But now that I have switched to Intel HD Graphics and everything is working perfectly :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.