1

AirVPN connection establishes successfully via NetworkManager, however web addresses cannot be resolved.

$ ping google.com
ping: unknown host google.com

I made the NetworkManager configuration as it is described in the official website by the staff:

  1. Choose your OS: Linux
  2. Choose server: Netherlands
  3. Connection modes: "Direct, protocol UDP, port 443 (*) " is checked.
  4. "Advanced mode" is checked.
  5. "Separate keys/certs from .ovpn" file is checked.
  6. Configuration file is imported to NetworkManager & connected via NetworkManager.

This issue is nonexistent when AirVPN connection is made via openvpn command on terminal.

$ sudo openvpn AirVPN_Netherlands_UDP-443.ovpn
Fri Oct  7 22:39:45 2016 OpenVPN 2.3.10 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Feb  2 2016
Fri Oct  7 22:39:45 2016 library versions: OpenSSL 1.0.2g  1 Mar 2016, LZO 2.08
...
...
Fri Oct  7 22:39:54 2016 Initialization Sequence Completed

There is no problem without NetworkManager:

$ ping google.com
PING google.com (216.58.204.46) 56(84) bytes of data.
64 bytes from lhr25s12-in-f14.1e100.net (216.58.204.46): icmp_seq=1 ttl=55 time=64.3 ms

I added OpenDNS addresses into "Additional DNS servers" textbox in the "IPv4 Settings" window of NetworkManager but it did not help.

How can I solve this issue?

  • I contacted support for the exact same issue, and received the following response: After years and years of problems, we do not provide support anymore to network-manager-openvpn, we're sorry. Please run our free and open source client Eddie or OpenVPN directly. However, I found this answer recommending to switch "LZO Data Compression" on (in VPN > Advanced). It works, but the connection still drops sometimes. – Jonathan Y. Aug 24 '17 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.