0

I have created a bootable USB media (external USB drive, not an USB stick) from the 64bit Ubuntu Server 16.04 ISO image. Various tutorials explain how to do this. This time I used rufus from windows 10 using this tutorial: http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-windows

However, the 16.04 server installation is hardcoded to work on /cdrom which, obviously, does not exist. The installation does not work. enter image description here enter image description here

I found this (old) thread, but the tricks described did not help. fail to install ubuntu server 14.04 64bit LTS from USB drive

I also searched for other alternatives (like installing over the network), but I could not find an easy solution. It seems quite outdated to hardcode the installation path to a hardware device (remember floppy drives?).

What is the easiest way to install Ubuntu Server 16.04 without a CD ROM?

  • 1
    How did you create the USB stick? The 'hardcoded' cdrom is actually not just the CDRom, but the ISO, and I've done numerous server installs from USB so I know it works out of the box. Depending on how you create the USB stick depends on how the system 'boots' to the installer (and it works fine via USB) – Thomas Ward Oct 7 '16 at 17:20
  • The 16.04 is not hard coded to work only with CDROMs. Very few people are using CDROMs for their installations as compared to the LiveUSB. Where did you get your ISO and how did you create the USB stick. – L. D. James Oct 7 '16 at 17:21
  • I used rufus (from windows 10), as described on the official ubuntu site (I just added the link in my question). Before, I tried with Win32 DiskImager (iirc) with the exact same result. It boots just fine, but /cdrom is not there. – Patrick Stalph Oct 7 '16 at 17:22
  • Yes, it is hardcoded to search installation resources on /cdrom. I've downloaded the latest server iso from ubuntu.com/download/server – Patrick Stalph Oct 7 '16 at 17:23
  • Are you trying to install to an EFI disk? Does your Drive already have an OS, if so which OS? – L. D. James Oct 7 '16 at 17:26
0

I was thinking the same thing. Burn the ISO using RUFUS with a USB stick instead. Make sure you select the proper OS in RUFUS. Curious to see if it works out. Let us know.

0

Ok, the key problem is the "external USB drive". I did the exact same thing with an "USB stick" and it works out of the box. It seems the USB stick is mounted differently and redirection to the ISO works as intended.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.