3

I'm going mad with this issue, that came out of all a sudden! Briefly, if I try to connect my svn server, I receive the following:

$ svn list svn://host
svn: E170013: Unable to connect to a repository at URL 'svn://host'
svn: E210005: No repository found in 'svn://host'

Of course svnserve is running on the default port (3690) and

telnet host 3690

is regularly working.

No firewalls, server nor client-side.

svn projects and repos are regularly working locally.

  • Is the svn root actually at / on host? if not, don't you need to give the path to a repository e.g. something like svn list svn://host/svn/somerepo? – steeldriver Oct 7 '16 at 16:23
  • the repository is in /var/www/myrepo and svnserve has been started in all possible ways: svnserve -d /var/www or svnserve -d /var/www/myrepo with no luck – jasmines Oct 8 '16 at 7:02
  • So do you get the same result when you try svn list svn://var/www/myrepo? – steeldriver Oct 8 '16 at 8:32
  • Do you mean locally? – jasmines Oct 8 '16 at 17:35
  • Sorry - brainfart. I meant svn list svn://host/var/www/myrepo – steeldriver Oct 8 '16 at 17:37
1

another thing to check:

I setup a new svnserve and was connecting for the first time, but I got an error:

svn: E170013: Unable to connect to a repository at URL 'svn://host/path'  
svn: E210005: No repository found in 'svn://host/path'

(aside normal client nmap -Pn host -p3690 being open, the server itself gave same error with svn list -v file:///path, where it should list at least a revision zero)

SO, for me, turned out to be a leading whitespace in my /path/conf/svnserve.conf (i.e. I only removed the pound sign, and left a single space before anon-access and auth-access); and sorry, I forget which command gave me the clue, but I got an error

svn: E200002: line 20: Option expected

which was the anon-access line in svnserve.conf.

0

There can be multiple things to check here.

  1. Can you check on server using svn list file://... your server is giving list of files ? - (This should work I think you already mentioned.)

  2. If the above command works then your local setup is correct but there is small thing that is missing here. Please check this link steps to setup svnserve using https:// or using svn://

  3. Please check whether your server daemon has started with -r option ? Without this client needs to provide the whole path for the access. svn://host.example.com/var/www/myrepo/project1 if the server is started with -r option then it should be svn://host.example.com/project1

  4. Check svn-director/conf/svnserv.conf file and see whether repository you would like to access has proper access for the user you are connecting from. This is required as without user access it might possible that repository is not readable. For reference of svnserv.conf this.

  5. Have you setup apache and can you access the repo with https://localhost.

For debugging please run the server daemon with --foreground to get logs and easy view.

Please let me know if still this doesn't work.

  • @jasmines..have you got chance to try this.? – Harshit Oct 14 '16 at 1:59
0

Edit your "servers" configuration file to indicate which proxy to use.

The file location is in "~/.subversion"

Uncomment and set the following lines:

#http-proxy-host=my.proxy
#http-proxy-port=80
#http-proxy-username=[username]
#http-proxy-password=[password]

I don't have your software so cannot test it myself but I hope this helps.

0

have you checked your svn version has not changed ?

you might have had a package manager update it in a batch of other changes.

Run this command to show the version and other details about the subversion package

apt-cache show subversion

There can be issues connecting to a 1.7 repository with a 1.9 client, if this where the case there would be messages in the server log and on stdout when the svn client is run.

0

Check you proxy settings in TortoiseSVN->Settings->Network.

Maybe they are configured differently than in your web browser.

Or else try out,

Disable/uninstall the VPN software(if you are using it) in order to use the SVN repository.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.