13

Updated Ubuntu 16.04 today using the software updater. Now my PC is running Kali? There were something like 2Gb of updates, which I thought at first was because I haven't updated in a while. Now I'm thinking that it was downloading Kali. Here's a video of the new boot-up process.

The screen will continue to flicker for another 30 seconds or so, then stop flickering leaving the text on the screen. I tried switching the display manager from gdm to lightdm, which will boot me straight to the console and without flickering, but still no desktop.

I'm not altogether sure how I managed to accomplish this. It must have been when I was trying to get Katoolin running.

Any tips as to how I can either get the desktop or revert the updates?

Contents of cat /etc/lsb-rolling:

DISTRIB_ID=Kali
DISTRIB_RELEASE=kali-rolling
DISTRIB_CODENAME=kali-rolling
DISTRIB_DESCRIPTION="Kali GNU/Linux Rolling"
  • 1
    - did you have kali as a source? - edit the results of cat /etc/lsb-release to the question please. – Rinzwind Oct 7 '16 at 8:42
  • Added contents. I was playing with adding Kali apps awhile back. Didn't realize it made these kind of changes. – kneeki Oct 7 '16 at 9:04
  • 5
    This issue is kind of epic. – gecko Oct 7 '16 at 19:59
  • 6
    Note to close-voters: This problem IS about Ubuntu! Katoolin/Kali Tools is valid here. Therefore, as this problem was caused by Katoolin on Ubuntu, the question itself is about Ubuntu. – Kaz Wolfe Oct 8 '16 at 17:20
  • 3
    @gecko I agree. I had a ! on top of my head for a while thinking no this can't be. – Rinzwind Oct 9 '16 at 15:10
14

Yes, you are now using Kali.

I consider this far too destructive and I would file a bug report for this if I was you. Our upgrade should not upgrade you to another (aka. unsupported by Canonical) operating system. Either it should give a big fat warning that there is a personal archive or it should automatically disable manually added personal archives.

What happened is that all packages got updated and those related to Kali also pulled in anything related to Kali. Making it cascade into replacing your system with Kali.

You can remove Kali by disabling their archive and then execute ...

sudo apt install ubuntu-desktop

but ... it will likely be easier and quicker to re-install if that is possible.

OP Update:

I was unable to get the Kali archives removed and migrate my install back to Ubuntu 16.04. I decided to cut my losses and install fresh, but didn't want to lose any data.

Backup

I booted to the Kali console and logged in to my old user account. I then Used sudo fdisk -l | more to get a list of drives after I plugged in my usb drive. The new drive was /dev/sdb1.

Tip: I made sure that I had enough space on my drive by using du -sh * while in my home directory.

To mount the drive, I issued the following:

sudo mkdir /media/usb/
sudo mount /dev/sdb1 /media/usb

I then copied my files using cp -rv * /media/usb/.

  • I'm not all together sure how I managed to accomplish this cluster... It must have been when I was trying to get Katoolin running. I think first I'll back up my home folder and then restore the Ubuntu desktop. Thanks for your help explaining what happened! – kneeki Oct 7 '16 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.