I've installed Ubuntu 11.10 on a Dell Inspiron N5010. It gets too hot and is automatically shutdown. Can anybody suggest why this is happening and how to fix it?

The application is use the most often are:

  1. Eclipse with android plugin
  2. Banshee player
  3. GIMP
  4. Wine

The output of lsmod is:

Module                 Size   Used by
bnep                   17923  2 
rfcomm                 38408  8 
pci_stub               12550  1 
vboxpci                22882  0 
vboxnetadp             13328  0 
vboxnetflt             27211  0 
vboxdrv               251814  3 vboxpci,vboxnetadp,vboxnetflt
parport_pc             32114  0 
ppdev                  12849  0 
binfmt_misc            17292  1 
joydev                 17393  0 
btusb                  18160  2 
bluetooth             148839  23 bnep,rfcomm,btusb
snd_hda_codec_hdmi     31426  1 
snd_hda_codec_idt      60049  1 
arc4                   12473  2 
dell_wmi               12601  0 
sparse_keymap          13658  1 dell_wmi
uvcvideo               67271  0 
dell_laptop            13519  0 
dcdbas                 14098  1 dell_laptop
videodev               85626  1 uvcvideo
snd_hda_intel          28358  2 
snd_hda_codec          91754  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep              13276  1 snd_hda_codec
snd_pcm                80468  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi           13132  0 
snd_rawmidi            25241  1 snd_seq_midi
snd_seq_midi_event     14475  1 snd_seq_midi
snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
snd_timer              28932  2 snd_pcm,snd_seq
intel_ips              17753  0 
snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
psmouse                63474  0 
serio_raw              12990  0 
iwlagn                273937  0 
mac80211              393459  1 iwlagn
snd                    55902  14 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
cfg80211              172392  2 iwlagn,mac80211
i915                  505143  8 
soundcore              12600  1 snd
snd_page_alloc         14108  2 snd_hda_intel,snd_pcm
wmi                    18744  1 dell_wmi
mei                    36466  0 
drm_kms_helper         32889  1 i915
drm                   196322  4 i915,drm_kms_helper
i2c_algo_bit           13199  1 i915
video                  18908  1 i915
lp                     17455  0 
parport                40930  3 parport_pc,ppdev,lp
usbhid                 41905  0 
hid                    77367  1 usbhid
ums_realtek            13096  0 
usb_storage            44173  1 ums_realtek
uas                    17699  0 
ahci                   21634  4 
libahci                25761  1 ahci
r8169                  47200  0 
  • Does the same thing happen under Windows during high cpu usage? – William Nov 28 '11 at 12:51
  • no that's not happen under windows(Windows 7) – Baya Nov 28 '11 at 12:56
  • Hmm, do you have dual graphics cards? Enabling the power saving or integrated graphics instead of the nicer card might help. How is the battery life? – William Nov 28 '11 at 13:51
  • sorry, i'm not aware of tat.. i'm new 2 ubuntu.. pls guide me 2 how to check tat.? – Baya Nov 28 '11 at 14:49
  • Hmmm.. check if amd-ccle is installed. Search for catylyst control center in the dash. – William Nov 28 '11 at 18:55

Maybe if you reduce Kernel power consumption it will help you a little. When I've installed 11.10 I had big problems with that (processor in idle constantly on 85 degrees) and this workaround and the “Workaround by editing GRUB” part helped me quite a lot (now it's around 60 degrees). I found this article thanks to another Ask Ubuntu issue where it's also suggested to install Jupiter applet which also helped me to reduce the temperature even more...

Workaround using Sysfs (temporary, use for testing)

Note: It seems that in the most recent kernel revisions ASPM is disabled on pre PCIe 1.1 devices and must be manually enabled using pcie_aspm=force kernel parameter (the second method in this article). So if it happens that when you try Sysfs method you receive Operation not permitted error, then you can skip to the "Workaround by editing GRUB" method.

Sysfs is a virtual file system used (amongst other things) to configure Linux hardware options from userspace. You can control your hardware options in real time by writing into what appear as text files. First let's check the state of things:

cat /sys/module/pcie_aspm/parameters/policy

The output of this command will probably be something like this:

[default] performance powersave

This means that the default PCIe ASPM (Active State Power Management) profile is selected. This "default" is where the problem lies. To work around Linux kernel 2.6.38 power regression we must force PCIe ASPM to be enabled. For ASPM to be enabled we must make sure that it stays off the "default" and "performance" profiles. This is how you can do it using Sysfs on Ubuntu based Linux distributions:

echo powersave | sudo tee /sys/module/pcie_aspm/parameters/policy

This setting remains until you change it again using sysfs or until you reboot, so is useful for testing whether PCIe ASPM is working on your configuration. This is necessary because there are reports of PCIe ASPM causing lockups when enabled on systems with buggy ASMP BIOS implementation. If this option isn't causing problems on your laptop or desktop system you can proceed to configure ASPM by editing GRUB or you can use sysfs to enable this option using an init script.

Workaround by editing GRUB (permanent)

After you've make sure that PCIe ASPM isn't causing problems on your configuration you can apply this workaround for good by editing GRUB configuration like this:

sudo nano /etc/default/grub

Now you find the GRUB_CMDLINE_LINUX_DEFAULT line that might look like this:


You should edit this line to look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force"

This way you are passing pcie_aspm=force kernel argument to force PCIe ASPM. This settings will be applied every time you boot your laptop or desktop. To make changes effective after editing the file, run:

sudo update-grub

The problem could be due to the use of a proprietary graphics driver (assuming you have the ATI/AMD graphics card) that is not updated with updates manager. All you have to do is go to Settings > Additional Drivers and click on ATI/AMD proprietary FGLRX graphics driver and click activate. The driver will be downloaded and restart your computer.


If you have a Dell n5010 I assume it's really old. Let me tell you my own experience:

I got an old n5010 from my gf and installed Ubuntu 16.04, it was overheating a lot and running slow, i5, 4gb of ram and Ubuntu, running slow. Ok, so I tried a lighter OS, installed MATE... Still overheating. Installed a processor clock widget and tried to downclock the processor to 1.86 Ghz, 1.6 Ghz, still overheating and slow.

So the last thing to try was Hardware. Some upgrades I made, as didn't want to spend a lot of money on a pc that is going to die soon: just bought a SSD (that I can install in a newer pc if I need), some thermal paste, isopropyl alcohol, and some love.

Opened my pc to check the cooler, and boom, the dirt over there looked like a stuffed animal, I cleaned it all, changed the thermal paste, installed the SSD and it looks like NEW.

So, if you have tried a lot of softwares and nothing has worked, try to clean your hardware, and replace your thermal paste.

Just one more thing, I used to notice that the pc was overheating next to the on/off button, always though it was the processor, but actually was the hot air that couldn't escape. So, check where it overheats, can be the processor, the hard drive, the graphics chip or it might just need a little maintenance.

This link might help: https://www.parts-people.com/blog/2012/04/18/dell-inspiron-15r-n5010-heat-sink-fan-removal-and-installation/


If you have an ati graphics card in your laptop then the default opensource driver causes the laptop to overheat. You can use the proprietary fglrx driver from amd.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.