10

I am new to Ubuntu and have no sound coming from my laptop speakers, external speakers via audiojack, or bluetooth headphones.

I have confirmed that the speakers and headphones work, and that all of the sound is definitely not muted. I have uninstalled and reinstalled Alsamixer and installed pulseaudio. I have identified my sound card (nvidia) and installed the latest drivers, then uninstalled them and installed them again. I have opened this file using gedit: gksu gedit /etc/modprobe.d/alsa-base.conf per instructions on another answer (No audio after fresh install of 15.04) and pasted this line at the bottom of the file: options snd-hda-intel model=3stack

These all solved the issue for other users but not for me.

Interestingly, in pulseaudio under the playback tab, the sounds of my music are registering, just not being output to any of my devices.

  • Maybe a stupid question, but if you open the sound settings: i.stack.imgur.com/tpVH7.png is the correct output device selected? (You can reach it by clicking on the speaker button in the top bar next the clock, and then by clicking "Sound Settings" ). If not try fixing the selection and use the Test Sound button – Dan Oct 14 '16 at 14:22
  • "These all solved the issue for other users but not for me." this very much smells of a bad user setting in ~/.config/pulse/or ~/.pulse/ whichever you use. See my answer here on how to remove these and some more suggestions. – Takkat Oct 14 '16 at 19:07
  • Dan - yes the correct output device is selected, when my headphones are not connected (such as right now), the only sound output device is GF106 High Definition Audio Controller, which I presume is the speakers either for the laptop or the ones plugged into the audio jack? When I press test sound nothing happens. There are no stupid questions! thanks for asking! – jenboi Oct 15 '16 at 23:23
  • Takkat - I am working through the suggestiions in your link (So far, no changes) but on step 4. "Make sure users are not in the 'audio' group" there are no steps on how to do that. Can you expand? OR, since I installed Ubuntu Mate myself, and am the only user so far, so does that mean I don't have to? – jenboi Oct 15 '16 at 23:34
  • 2
    Did you try to mv /home/jenboi/.config/pulse /home/jenboi/.config/pulse.bad then restart pulseaudio? From the log you will only have sound through HDMI as other internal sound cards were not detected. See with aplay -L whether ALSA detects any of your sound devices cards. – Takkat Oct 20 '16 at 6:29
1

Have you installed the media codecs. It's common for beginners to forget to install the mp3 codecs. If not open up your terminal and type in the following

sudo apt-get install ubuntu-restricted-extras
1

The 15.04 can be buggy at times. Have you done

sudo apt-get install build-essential

before installing PulseAudio? If not, do it. The audio functions too need essential libraries and compilers at time. Now I know this is basic, but perhaps, it may have been overlooked. It had happened to me a couple of days ago.

So next, check this:

  1. Go to the dash on the top-left corner of your screen
  2. Type in pulseaudio and open the pulseaudio volume control
  3. Open an mp3 file and let it play while you check these two tabs. Check the options available one-by-one and select the one which allows you to listen to the mp3 file being played. Output devices Configuration
  4. If/when you will have been successful in fixing your problem, go brew yourself a warm latte.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.