I just installed Ubuntu Server (latest from ubuntu website). I successfully installed the OS on my laptop. Now how to install GUI?

I tried the following commands:

sudo apt-get install gnome

sudo apt-get install xorg gnome-core gnome-system-tools gnome-app-install

It gives error "Unable to locate package gnome".

Is it due to network connection? I cannot enable my wireless card externally (From keyboard). When I try ping command it says "unknown host".

Thank you.

  • No. Not working. Gives same error "Unable to locate package". – CH325 Oct 5 '16 at 16:32
  • Can I install the GNOME package offline, like downloading the package separately and burning on CD or USB? – CH325 Oct 6 '16 at 9:29
  • apt-cache search gnome | grep "^ubuntu" . Check the output that you have available package for gnome-desktop. – sohel4r Oct 8 '16 at 5:56
  • I made some changes in description. Please refer to that. But I found the solution. Read the solution in Answers section. – CH325 Oct 8 '16 at 6:08
  • Did you run sudo apt-get update before trying to install the packages? – Byte Commander Oct 9 '16 at 1:33

Try installing Gnome Desktop

sudo apt-get install ubuntu-gnome-desktop
| improve this answer | |
  • No. Not working. Unable to locate package. – CH325 Oct 6 '16 at 1:33

OK. I finally found the reason behind the problem. My wireless card was not working because I had never configured it. During the installation of the OS I had skipped the wireless card configuration process. So the solution is to configure the wireless card while installation.

After the complete installation, while connecting to the access point, I encountered a problem, which I like to discuss, along with the solution.

Initially, the card is on off state. To wake it up, we type

ifconfig interface_name up

Where "interface_name" is the name of your wireless card. For different systems, the name varies. To get the name for your system, type iwconfig

You may encounter an error "Error:Operation not possible due to RF-Kill"

This is because your wireless card is been disabled externally.To overcome this error, without typing any other command press the WIFI button your keyboard. After you press the button, type ifconfig interface_name up again. Your Wifi will be in active state.

To connect to available networks follow this link

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.