7

I just got a new Razer Blade Stealth and I immediately proceeded to installing ubuntu on my laptop and erasing windows. What happened was that during installation, whenever I uncheck the caps lock on my keyboard, the computer crashes (the screen becomes fragmented? into gibberish).

Now I've finished installing it.. it is still crashing whenever I uncheck the caps lock.

  • Does your caps-lock have a light? If so, is it blinking when this happens? – TheOdd Oct 5 '16 at 14:32
  • It does have a light but it doesn't blink... – Tingkai Liu Oct 5 '16 at 14:41
  • Oh, ok. I was checking because of this issue: 8.10 randomly freezing caps lock blinking flashing – TheOdd Oct 5 '16 at 14:45
  • Thanks Owen, I saw that one too but it doesn't seem like my problem – Tingkai Liu Oct 5 '16 at 15:19
  • I reduced resolution to 1920*1080 and now it looks fine. – Tingkai Liu Oct 5 '16 at 19:04
2

I have the "new" 2016 razer blade stealth; upgraded to Ubuntu 16.10. I had the same problems with the caps lock key crashing.

Workaround: Disable Caps Lock

Obviously this completely disables the caps lock key, but it also prevents it from crashing the system.

Ubuntu

Go to Tweak tool -> typing -> caps lock key behavior, change to "Caps Lock is disabled".

Kubuntu

Go to System Settings -> Hardware -> Input Devices -> Keyboard -> Advanced, in the section Caps Lock key behavior enable Caps Lock is disabled.

  • Sorry I just saw this. I think the problem with it is that the Intel HD 720(or 620 I forgot) is not fully supported. The driver keeps crashing the computer for no reason ( not just with Caps Lock, I actually had problem with normal shut down of the system). I did use xmod to completely disable Caps Lock like what you suggest but I ended up just not using Ubuntu coz of the shut down problem. – Tingkai Liu Oct 20 '16 at 19:56
  • I was having constant problems with 16.04, I upgraded to 16.10 a couple days ago and it is MUCH more stable, I'm going on 2 days w/o a crash. – greensilex Oct 20 '16 at 20:28
  • 2
    I think that this answer should be upvoted but not accepted, because this answer does not solve the problem, it only provides a workaround. Which is great as long as there's no solution, but still. – Christian Hujer Dec 31 '16 at 7:50
  • The tweak tool didn't have the typing option for me, but I found if I used dconf-editor to set caps:none in the xkb options, it worked. I have the 2016 razer balde stealth. – Anthony Scopatz Jan 4 '17 at 23:45
  • This is not a viable solution. – Nick Desaulniers Jan 19 '17 at 5:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.