75

In System Settings > Bluetooth, the Bose QC 35 is visible when searching for devices but pairing fails.

After multiple attempts and playing with the PIN options I managed to pair it but once selected in System Settings > Sound, it would fail and fall back to Built-in Audio or playback some garbled sound.

  • Likely an issue with this bug – Jeremy31 Oct 5 '16 at 10:36
  • 3
    About the garbled sound: I had this too but just needed to go to pavucontrol -> "Configuration" (tab), and then for the Bose QuietComfort 35 profile select "High Fidelity Playback (A2DP Sink)". Hope this helps! – sunyata Nov 30 '16 at 16:28
  • The issue I have with "A2DP sink" is that you cannot use the microphone (it defaults back to the other) – Martin Marconcini Mar 9 at 0:40
131

It seems the Bose Quiet Comfort 35 does has issues with pairing with Bluetooth LE (Low Energy).

Get back to a clean state

I would recommend to clean up you past attempts to pair:

  • On Ubuntu, remove the headphones from the Bluetooth paired list.
  • On the headphones, hold the switch in Bluetooth pairing position for 10 seconds to delete all paired devices (You'll get a voice confirmation).
  • If you can, deactivate Bluetooth on other surrounding devices to make sure they won't interact.

Deactivate Bluetooth LE

Edit Bluetooth configuration file:

sudo nano /etc/bluetooth/main.conf 

Replace:

#ControllerMode = dual

with:

ControllerMode = bredr

Restart Bluetooth:

sudo service bluetooth restart

Pair

  1. Make sure the headphones are in pairing mode.
  2. Pair with System Settings > Bluetooth
  3. Select & test the headphones in System Settings > Sound. You may want to choose High Fidelity Playback (A2DP Sink) for high playback quality.

Reactivate Bluetooth LE (optional)

As it is only the pairing that has to be done without Bluetooth LE, once it is paired you can go back to the original configuration:

sudo nano /etc/bluetooth/main.conf 

Replace:

ControllerMode = bredr

with:

#ControllerMode = dual

Restart Bluetooth:

sudo service bluetooth restart

Troubleshooting

If you have issues connecting back after disconnecting/rebooting:

  • Make sure you have the computer and Bluetooth turned on before the headphones.
  • If Connection is grayed out in System Settings > Bluetooth, you can use the Bluetooth menu in the menu bar (next to the clock) to do Connection On/Off.
  • 4
    @Galgalesh You have to choose High Fidelity Playback (A2DP Sink) in System Settings > Sound. – Victor Dec 29 '16 at 18:20
  • 2
    For me the solution worked once. After two weeks i removed all my Bluetooth devices. Now when i am try to connect the Bose headphones like described in the solution, but every times 'setting up "Bosequietcomfort 35" failed' shows up. Over terminal bluetoothctl shows me the device connected, but in the Bluetooth UI not and even the sound settings. What can i additionally try? – marsUbuntux Jan 24 '17 at 7:44
  • 1
    Worked on my Bose AE2 Soundlink :) – Nick Feb 15 '17 at 12:52
  • 2
    This worked with my Base QuietControl 30's on Ubuntu 16.04.10. – Sean Glover Aug 23 '17 at 19:32
  • 1
    For me, the additional steps outlined in this answer (modifying /etc/pulse/default.pa) made it work. – sunside May 24 '18 at 9:20
39

The accepted answer did not work for me. This blog entry worked: http://erikdubois.be/installing-bose-quietcomfort-35-linux-mint-18/

  1. Create /etc/bluetooth/audio.conf

    [General]
    Disable=Socket
    Disable=Headset
    Enable=Media,Source,Sink,Gateway
    AutoConnect=true
    load-module module-switch-on-connect
    
  2. In /etc/bluetooth/main.conf set

    ControllerMode = bredr
    AutoEnable=true
    
  3. Restart bluetooth

  4. Connect your headphones
  5. Choose High Fidelity Playback (A2DP sink)-mode in sound options
  • Mine worked here too and I was even able to change the ControllerMode back to dual once the setup was complete. – RexFuzzle Jun 7 '17 at 7:11
  • Worked for me. My QC35 was not connecting, until I follow the exact path: Dont start QC35 yet, Open System Settings > Bluetooth, click +, then start QC35 and you will see the name added. – SM Adnan Jun 15 '17 at 23:57
  • This was helpful for me. In addition, I had to update the Broadcom WiFi driver to the latest version following the instruction here to resolve an issue with stuttering audio playback. – mikkola Sep 18 '17 at 19:51
  • 1
    This worked for me. Steps: Unpair qc35 from previous attempt (bletoothctrl, then delete device). start scan for new device. Trigger new pairing in bose companion app. – heeen Oct 27 '17 at 9:55
1

The solution above didn't work for me. I got it to work, but you need to set it up manually every time you reboot.

  1. First close bluetooth and bluez by effectively stopping them (not restarting), then starting them again using systemctl start bluetooth and sudo /etc/init.d/bluetooth start.
  2. Start bluez manager and connect the device using setup with the audio sink profile.
  3. Manually change sound to the headphones.

I am a newbie with scripts, maybe someone more experienced than me can make a script that does all these actions at boot.

0

I have the Bose Quietcomfort 35 II on Linux Mint 19.2. None of the solutions here worked for me. The only thing that worked was downloading the Bose Connect app on my Android phone and:

  1. Connect your headphones to the phone
  2. Connect your headphones to the Bose app
  3. Go to "Connections" and make your headphones ready to connect
  4. Pair with blueman or blueberry
  5. Now both your phone and your computer will be connected. You can now disconnect your phone.

You won't have to do this again because the devices will be paired.

protected by Community Nov 30 '17 at 18:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.