0

I've taken a long path installing Opensatck Autopilot till reached at this point. The problem now is that after a floating ip association to the new instance I'm unable to ssh to it from where I'm used to sshing to all physical nodes. When I poking around in a report generated by juju status in juju inner environment it seems some of services have a current status of either blocked or error. Like

neutron-gateway/0:

workload-status:       
current: blocked

message: 'Services not running that should be: neutron dhcp-agent, neutron-vpn-agent'

The log file /var/log/neutron/dhcp-agent.log on machine 0 which neutron is placed also is here. It says something about "Timeout in RPC method". Actually most of network related services are not working properly as it declared when I ran neutron agent-list command on a node Network services are deployed, including "open vswitch agent".

Another rather less important problem Ibe experienced is that when attempting to deploy juju-gui in inner juju environment I received this error:

ERROR cannot load cookies: file locked for too long; giving up: cannot acquire lock: open /home/ubuntu/.go-cookies.lock: permission denied

I'm totally helpless please anyone who know where should I begin debuging lift a finger and help

4
  • The permission denied error it could be because the user trying to acquire the lock is not the "ubuntu" user.
    – Katu
    Oct 5, 2016 at 8:40
  • Well first thank you, your hint helped. I changed the user to "ubuntu" but then it complained that error: cannot load ssh client keys: mkdir /var/lib/landscape/juju-homes/2: permission denied so I changed it to "root" and it worked (hopefully it wont have any side effects). now I have juju-gui installed in internal juju environment. But still bewildered how to solve the network issue for instances!!
    – Ali
    Oct 5, 2016 at 12:22
  • The blocked status should not affect ssh. Are you trying to ssh inside the lxc? That might only be possible from where the inner environment is bootstrapped. None the less did you try starting the neutron dhcp-agent, neutron-vpn-agent services manually? Oct 8, 2016 at 1:04
  • No, I try to ssh from my local machine in public network. Any way regarding your advice for manually starting "neutron dhcp-agent", I tried $ service neutron-dhcp-agent start on the machine that nuetron-gateway service is running and I got this error start: Rejected send message, 1 matched rules; type="method_call", sender=":1.9" (uid=1000 pid=99077 comm="start neutron-dhcp-agent ") interface="com.ubuntu.Upstart0_6.Job" member="Start" error name="(unset)" requested_reply="0" destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init ") . Any opinion what should I do next?
    – Ali
    Oct 9, 2016 at 12:40

1 Answer 1

0

Well it took lots of time inspecting different logs and running many command and also seeking help from real human being (since virtual world didn't stretch any hand) until I came across the neutron-ovs-cleanup service log which was error-ridden with

ImportError: cannot import name deploy

Then the quick guide given in this page did the rest. Well it was the incompatible version of this Python library (PasteDeploy) I guess that made the service fail and consequently led to other related networking services failure as well. So I ran pip uninstall --yes PasteDeploy && pip install 'PasteDeploy>=1.5.0' as instructed on the page above and all of a sudden it worked :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.