4

This question already has an answer here:

I'm using Ubuntu Xenial and mysql 5. editing the mysql.conf file didn't help. it's still showing active.

marked as duplicate by Elder Geek, Aaron, waltinator, amc, TheWanderer Oct 6 '16 at 2:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

8

Ubuntu 16.04 uses systemd to control autostart of services. Try using the systemctl command:

sudo systemctl disable mysql
  • 1
    Tried that on Ubuntu 17.10 several times .. but mysql starts on every boot. --- - - log ---- - - mysql.service is not a native service, redirecting to systemd-sysv-install. Executing: /lib/systemd/systemd-sysv-install disable mysql – cljk Oct 23 '17 at 7:34
  • I confirm this work in Ubuntu 18.04 too – Manuel Jordan Nov 3 at 16:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.