1

I recently upgrade my PHP 5.5 installation to version 5.6. The upgrade completed successfully (I assume) as the php version returned when viewed via php -v is:

5.6.26

However, when I try to spin up my page I get the following error in chrome:

The examplesite.com page isn’t working

examplesite.com is currently unable to handle this request. HTTP ERROR 500

I checked the Apache error logs and found this:

[Tue Oct 04 07:39:58.570181 2016] [:notice] [pid 16890] FastCGI: process manager initialized (pid 16890)

[Tue Oct 04 07:39:58.570420 2016] [mpm_prefork:notice] [pid 1187] AH00163: Apache/2.4.20 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 configured -- resuming normal operations

[Tue Oct 04 07:39:58.570434 2016] [core:notice] [pid 1187] AH00094: Command line: '/usr/sbin/apache2'

[Tue Oct 04 13:54:46.291520 2016] [mpm_prefork:notice] [pid 1187] AH00169: caught SIGTERM, shutting down

These same lines appear 3 or 4 times, though not when I access a page, only when I run the following commands:

sudo service apache2 reload
sudo service apache2 restart

I upgraded my PHP installation by following the advice from this post.

I ran the following commands to complete the upgrade:

sudo apt-get update
sudo apt-add-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get install php5.6
sudo apt-get update
sudo apt-get upgrade
sudo service apache2 reload
sudo service apache2 restart

Any advice on what I did wrong?

  • is apache running or not? can you post the ouput for this 2 commands : sudo apache2ctl -V and sudo service apache status – bistoco Oct 4 '16 at 19:33
  • @bistoco Sorry, I feel really stupid now. It turns out it wasn't an apache problem at all. During the PHP 5.6 upgrade, many of my php extensions were removed including the mbstring extension which is required in my app. Reinstalling the missing extensions fixed the problems. – War10ck Oct 5 '16 at 0:46
  • don't worry, the same happened to me, i should have noticed the 500 error too. – bistoco Oct 5 '16 at 1:13
1

So this was unexpected. It turns out my problem was not related to the above Apache logs at all. When I upgraded the PHP version from 5.5 to 5.6, many of my extensions including mysql, curl and mbstring were removed. Reinstalling these extensions using the appropriate commands below:

sudo apt-get install php5.6-mysql
sudo apt-get install php5.6-mbstring
sudo apt-get install curl libcurl3 libcurl3-dev php5.6-curl

combined with the Apache commands:

sudo service apache2 reload
sudo service apache2 restart

resolved all of my problems.

Apologies for the ignorance on this. I should have checked the extensions first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.