0

I'm trying to dual boot Ubuntu with Windows 10 (Legacy BIOS), but whenever I try and install, I get this:

dual boot

Is there a solution from here? Can I just press the option not to force UEFI, and carry on with installation?

I followed this guide exactly, but the "Force UEFI installation?" occurs at the "Preparing to install Ubuntu" stage.

  • 1
    If the machine is UEFI capable why on Earth have you installed Windows in Legacy? Now, if you need a proper dual boot you need to boot the Ubuntu installer in the same way, i.e., not UEFI. How it boots is how it installs. – user589808 Oct 4 '16 at 17:29
  • I upgraded from an old version of Windows, which I guess was installed in Legacy. I tried to boot it in non UEFI, but that takes me straight back to the Windows loading screen. Any ideas how to boot it in the same way? – Drummermean Oct 4 '16 at 17:35
  • 1
    Windows should boot the same exact way if you disable UEFI (= CSM or Legacy only). That way the USB should boot in legacy. Otherwise there will be two entry for the some drive; choose the one without UEFI. If it doesn't boot that way it means it was probably done with Rufus or similar tool that forces one mode or another. ubuntu.com/download/desktop/create-a-usb-stick-on-windows (notice the "partition scheme"; you need the option pictured - MBR - for booting in non-UEFI systems). – user589808 Oct 4 '16 at 18:35
  • 1
    Thanks, I'm now another stage further in dual booting. I believe the wrong selection was made before when creating the USB stick. I used Rufus and changed the partition scheme to MBR and it has now worked. Thank you! – Drummermean Oct 4 '16 at 20:21
0

I ran into a similar issue when attempting to dual boot Ubuntu 18.04 on a machine running Windows 10 with legacy BIOS. This process might help:

https://askubuntu.com/a/1069984/616171

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.