1

I'm running Ubuntu 16.04 and Windows 10 on 2 separate hard drives (no partitions, 2 physical hard drives).

Two things have happened:

  1. I no longer get the GRUB boot loader screen which allows me to choose which operating system I boot into (I recall that this used to work under a similar setting running Linux Mint 15 and Windows 7)

  2. Suddenly Windows 10 won't boot anymore. Even though I set it as the first drive to boot from in the BIOS.

What am I doing wrong here? I've seen some stuff about installing ubuntu in uefi mode. Is that something I need to consider? I am fairly new to Ubuntu and a complete noob when it comes to setting up partitions, etc.

Thank you,
BR
Johan

marked as duplicate by Pilot6, andrew.46, David Foerster, Kevin Bowen, Zanna Oct 5 '16 at 8:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did it ever worked? If so, what happened prior to Windows not booting? And if it's only Windows that isn't booting what does it have to do with Ubuntu? Yes, you need to learn about UEFI. Start here: help.ubuntu.com/community/UEFI – user589808 Oct 4 '16 at 17:10
  • Yes it used to work, grub bootloader did not show but if i set up the windows drive as nr 1 in bios it would boot into windows. I know this is not completely linux related but getting the grub bootloader to work, in my humble opinion is. If not then I apologize for wasting time. Thank you for the link I will check it out – Johan Oct 4 '16 at 17:13
  • If you needed that hack then you didn't have a proper dual boot because the OSes were installed in different modes, nothing to do with Grub as it can't work (for dual booting) in that situation. What's happening now is Windows related only. – user589808 Oct 4 '16 at 17:17
  • Yes it turned out that I had installed Ubuntu in legacy mode :( Very well nothing to do but reinstall it then I guess. Thanks for the help! – Johan Oct 4 '16 at 17:29
2

It looks as if this question has been resolved in the comments.

Yes it turned out that I had installed Ubuntu in legacy mode :( Very well nothing to do but reinstall it then I guess. Thanks for the help! – Johan

  • 3
    If on same drive with gpt partitioning, you can use Boot-Repair's advanced options to uninstall grub-pc and install grub-efi-amd64. That converts install from BIOS boot to UEFI boot. – oldfred Oct 4 '16 at 19:03
0

The problem was just like CelticWarrior mentioned that my ubuntu installation was installed in Legacy mode. After reinstalling it in UEFI mode everything now works. GRUB bootloader shows up and my Windows 10 installation now boots again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.