4

I got the following error message when trying to install Kompozer in Ubuntu 16.04.

saraswati@ubuntu:~$ sudo apt-get install libatk1.0-0 libc6 libcairo2 libfontconfig1 libfreetype6 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk2.0-0 libidl0 libnspr4 libnss3 libpango1.0-0 libpng12-0 libstdc++6 libx11-6 libxft2 libxinerama1 libxrender1 libxt6 zlib1g  
Reading package lists... Done  
Building dependency tree...
Reading state information... Done  
Package libidl0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libidl-2-0:i386 libidl-2-0

E: Package 'libidl0' has no installation candidate

Please help me to sort out this problem.

7

Install the same packages you tried to install before except for libidl0. Open the terminal and type:

Ubuntu 14.04-16.04

sudo apt install libatk1.0-0 libc6 libcairo2 libfontconfig1 libfreetype6 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk2.0-0 libnspr4 libnss3 libpango1.0-0 libstdc++6 libx11-6 libxft2 libxinerama1 libxrender1 libxt6 zlib1g   
  • 32-Bit:

    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-data_0.8%7Eb3.dfsg.1-0.1ubuntu2_all.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer_0.8%7Eb3.dfsg.1-0.1ubuntu2_i386.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libidl0_0.8.14-1_i386.deb
    sudo dpkg -i libidl0_0.8.14-1_i386.deb
    sudo dpkg -i kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
    sudo dpkg -i kompozer_0.8~b3.dfsg.1-0.1ubuntu2_i386.deb 
    
  • 64-Bit:

    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-data_0.8%7Eb3.dfsg.1-0.1ubuntu2_all.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer_0.8%7Eb3.dfsg.1-0.1ubuntu2_amd64.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libidl0_0.8.14-1_amd64.deb
    sudo dpkg -i libidl0_0.8.14-1_amd64.deb
    sudo dpkg -i kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
    sudo dpkg -i kompozer_0.8~b3.dfsg.1-0.1ubuntu2_amd64.deb 
    

Ubuntu 16.10-18.04

sudo apt install libatk1.0-0 libc6 libcairo2 libfontconfig1 libfreetype6 libgdk-pixbuf2.0-0 libglib2.0-0 libgtk2.0-0 libnspr4 libnss3 libpango1.0-0 libstdc++6 libx11-6 libxft2 libxinerama1 libxrender1 libxt6 zlib1g 
  • 32-Bit:

    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-data_0.8%7Eb3.dfsg.1-0.1ubuntu2_all.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer_0.8%7Eb3.dfsg.1-0.1ubuntu2_i386.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libidl0_0.8.14-1_i386.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libpng12-0_1.2.54-1ubuntu1_i386.deb  
    sudo dpkg -i libidl0_0.8.14-1_i386.deb  
    sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_i386.deb
    sudo dpkg -i kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
    sudo dpkg -i kompozer_0.8~b3.dfsg.1-0.1ubuntu2_i386.deb 
    
  • 64-Bit:

    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer-data_0.8%7Eb3.dfsg.1-0.1ubuntu2_all.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/kompozer_0.8%7Eb3.dfsg.1-0.1ubuntu2_amd64.deb
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libidl0_0.8.14-1_amd64.deb  
    wget https://launchpad.net/ubuntu/+archive/primary/+files/libpng12-0_1.2.54-1ubuntu1_amd64.deb  
    sudo dpkg -i libidl0_0.8.14-1_amd64.deb  
    sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_amd64.deb
    sudo dpkg -i kompozer-data_0.8~b3.dfsg.1-0.1ubuntu2_all.deb
    sudo dpkg -i kompozer_0.8~b3.dfsg.1-0.1ubuntu2_amd64.deb 
    
2

Above answer for Ubuntu 16.04 64-bit no longer works. Problem on sudo dpkg -i libidl0_0.8.14-1_amd64.deb:

john@Laptop:~/Software/Kompozer$ sudo dpkg -i libidl0_0.8.14-1_amd64.deb
[sudo] password for john: 
Selecting previously unselected package libidl0:amd64.
(Reading database ... 366612 files and directories currently installed.)
Preparing to unpack libidl0_0.8.14-1_amd64.deb ...
Unpacking libidl0:amd64 (0.8.14-1) ...
Replaced by files in installed package libidl-2-0:amd64 (0.8.14-4) ...
dpkg: dependency problems prevent configuration of libidl0:amd64:
 libidl-2-0:amd64 (0.8.14-4) breaks libidl0 (<< 0.8.14-3) and is installed.
  Version of libidl0:amd64 to be configured is 0.8.14-1.

dpkg: error processing package libidl0:amd64 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libidl0:amd64

Solved by:

sudo apt-get -f install
sudo apt-get remove libidl-2-0
sudo dpkg -i libidl0_0.8.14-1_amd64.deb

and then as before.

0

Problem referred to in my Comment on not working for 16.04 has been rectified in 18.04. However, on new installation of 18.04, am now getting: john@JohnPC:~/Software/Kompozer$ sudo dpkg -i kompozer_0.8~b3.dfsg.1-0.1ubuntu2_amd64.deb Selecting previously unselected package kompozer. (Reading database ... 264748 files and directories currently installed.) Preparing to unpack kompozer_0.8~b3.dfsg.1-0.1ubuntu2_amd64.deb ... Unpacking kompozer (1:0.8~b3.dfsg.1-0.1ubuntu2) ... dpkg: dependency problems prevent configuration of kompozer: kompozer depends on libpango1.0-0 (>= 1.14.0); however: Package libpango1.0-0 is not installed.

dpkg: error processing package kompozer (--install): dependency problems - leaving unconfigured Processing triggers for man-db (2.8.3-2) ... Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ... Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ... Processing triggers for mime-support (3.60ubuntu1) ... Errors were encountered while processing: kompozer

This error is rectified by sudo apt install libpango1.0-0 followed by sudo dpkg -i kompozer_0.8~b3.dfsg.1-0.1ubuntu2_amd64.deb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.