0

I run Ubuntu 14.04 LTS on my laptop. Due to dependencies, not many MySQL WorkBench versions are available for use. Hence, I am more or less forced to use 6.3.6 which suffers from a bug when exporting a DB. (Exception => Can't export DB as not root user.) The bug is described here.

There is available WorkBench 6.3.7 for download for Linux Ubuntu 16.04, but I just can't use it. Is there any chance to use this 6.3.7 in Ubuntu 14.04 ?

I mean, wouldn't it be great if Canonical elevated version of the pretty outdated workbench v.6.0.8 in their Software Center offer ?

These are my dependency errors, that prevent me to install 6.3.7

peter@peter-LIFEBOOK-S6420:~/Downloads$ sudo dpkg -i mysql-workbench-community-6.3.7-1ubu1604-amd64.deb
(Reading database ... 224508 files and directories currently installed.)
Preparing to unpack mysql-workbench-community-6.3.7-1ubu1604-amd64.deb ...
Unpacking mysql-workbench-community (6.3.7-1ubu1604) over (6.3.7-1ubu1604) ...
dpkg: dependency problems prevent configuration of mysql-workbench-community:
 mysql-workbench-community depends on libatkmm-1.6-1v5 (>= 2.24.0); however:
  Package libatkmm-1.6-1v5 is not installed.
 mysql-workbench-community depends on libcairo2 (>= 1.14.0); however:
  Version of libcairo2:amd64 on system is 1.13.0~20140204-0ubuntu1.1.
 mysql-workbench-community depends on libcairomm-1.0-1v5 (>= 1.12.0); however:
  Package libcairomm-1.0-1v5 is not installed.
 mysql-workbench-community depends on libglibmm-2.4-1v5 (>= 2.46.0); however:
  Package libglibmm-2.4-1v5 is not installed.
 mysql-workbench-community depends on libgtkmm-2.4-1v5 (>= 1:2.24.0); however:
  Package libgtkmm-2.4-1v5 is not installed.
 mysql-workbench-community depends on libncurses5 (>= 6); however:
  Version of libncurses5:amd64 on system is 5.9+20140118-1ubuntu1.
 mysql-workbench-community depends on libodbc1 (>= 2.3.1); however:
  Version of libodbc1:amd64 on system is 2.2.14p2-5ubuntu5.
 mysql-workbench-community depends on libpangomm-1.4-
dpkg: error processing package mysql-workbench-community (--install):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
^Cdpkg: error processing package shared-mime-info (--install):
 subprocess installed post-installation script was interrupted
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Errors were encountered while processing:
 mysql-workbench-community
 shared-mime-info

I would even try to install them one by one, but actually got nowhere..

  • Not an answer but there is also DBeaver. – Jos Oct 4 '16 at 10:02
  • "I mean, wouldn't it be great if Canonical elevated version of the pretty outdated workbench v.6.0.8 in their Software Center offer ?" No. "but I just can't use it" Oh? Care to share why not? As this stands I don't see anyone answering your =problem= of not being able to install 6.3.6 – Rinzwind Oct 4 '16 at 10:02
  • @Rinzwind Let me quote you and myself: R: Oh? Care to share why not?" P: "Due to dependencies, I am forced to use MySQL WorkBench 6.3.6 ..." R: "your =problem= of not being able to install 6.3.6" P: You are wrong. I did install and run WB 6.3.6 BUT ITS BUGGY as the link suggests. And I can't install 6.3.7 on 14.04 DUE TO insufficient DEPENDENCES :) Care to share why it wouldn't be great if Canonical'd upgrade its outdated software center packages ? – Peter Oct 4 '16 at 11:04
  • @Rinzwind Why is is that as soon as there is anything that might sound just a tiny bit like a complain about Canonical, immediately someone too wise raises making pple with less reputation a complete dull, however with better reading of the original post ... ehm... – Peter Oct 4 '16 at 11:06
  • 1
    @Peter " Care to share why it wouldn't be great if Canonical'd upgrade its outdated software center packages ?" That would violate 1 core rule of Ubuntu. Ubuntu is about stable software. And stable means the version it was during the feature freeze of Ubuntu. "But still I need that update cause 6.3.6 has that bug" No, you do not. 6.3.4 does not have that bug (as noted in the bug report). – Rinzwind Oct 4 '16 at 14:56
0

It looks like MySQL isn't supporting anything before Xenial anymore for MySQL workbench, which suggests it might not be possible to make it work on just 14.04. (Yet another reason to upgrade...)

In my comments above, I neglected to take into account I have a Xenial chroot on my computer, which is where some things run from (like MySQL workbench, albeit not as kindly as I'd like it to). Because of this, I forgot that I don't have a 'pure' 14.04 install. Given this, however, I believe it's not possible to get the latest "generally available" prebuilt binaries.

There is a source code tarball available from MySQL, you may wish to download and compile MySQL workbench latest from source to see if that works, but I can't provide any guarantees it'll work.

  • That is exactly what I was afraid of.. I even tried to export my DB using provided 6.0.8 and it ain't work either ! Not an exception though, but the process hangs and never ends. DB is no bigger than 10 MB Now I get really upset about Oracle open source SW :) Perhaps they just try to give us another reason to buy the real SW :) – Peter Oct 4 '16 at 15:01
  • @Peter I would consider using mysqldump instead, rather than the GUI, to get the DB dump. It should work, while Workbench might not. – Thomas Ward Oct 4 '16 at 15:03
  • Thanx, I'd also go for Jos' suggested DBeaver alternative do WBench. – Peter Oct 5 '16 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.