I received the following error message; not sure what caused it, but it possibly followed opening LibreCalc's Cell Formatting options box, with Ctrl + 1.

Title: "Installing fonts on request isn't supported"
Message: "Currently auto-detection and installation of missing fonts is not supported"

Web showed no results for this error. Should I go to ask.LibreOffice.org?


2 Answers 2


This looks like a document that was created with Windows and the fonts are not installed. Try installing the MS-Corefonts:

sudo apt-get install ttf-mscorefonts-installer

That should fix your problem.

There are meta-packages for restricted extras, like codecs and fonts. This depends on your desktop-environment. Choose one of them.

sudo apt-get install ubuntu-restricted-extras   # Gnome based
sudo apt-get install kubuntu-restricted-extras  # KDE
sudo apt-get install lubuntu-restricted-extras  # LXDE
sudo apt-get install xubuntu-restricted-extras  # XFCE

Maybe I found a solution:

As I had had those ms-corefonts installed before, they couldn't be the cause of the error message.

I concluded the cause must have been me having deinstalled all Asian fonts; I did not want to reinstall them with those meta-packages.

Here's what I did - and I haven't seen the message since:

In LibreOffice, go to

  • -> Tools
  • -> Options
  • -> Language Settings
  • -> Languages

Under "Default Languages for Documents" I had unticked the boxes for "Asian" and "Complex Text Layout" before,

  • -> so I ticked them now
  • -> both settings hold scrollable lists of languages:
  • -> I selected the top entries: [None]

clicked OK & that's it!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .