1

I have been trying to install MySQL 5.7 but there is some error occurring on Ubuntu 14.04 while installing other package like unzip, phpmyadmin. I am getting following error when I have tried to install other packages.

The following packages have unmet dependencies:
 mysql-server : Depends: mysql-community-server (= 5.7.15-1ubuntu14.04) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
2
  • Please mention the Ubuntu version. Also were you trying to install this package from a deb not from Ubuntu repository?
    – Nisheet
    Oct 4 '16 at 6:26
  • @Nisheet It's Ubuntu 14.04 Oct 4 '16 at 6:27
0

Have you downloaded the deb package of mysql-server (5.7) from a third party side?

If yes.The most probable answer is that your version of mysql-server has dependencies that are not available in Ubuntu 14.04 repository.

One way would be to download the missing package(mysql-community-server (= 5.7.15-1ubuntu14.04)), and install it manually

$ sudo apt-get install <missing-package-1> <missing-package-2> ....

Or remove the mysql-server, sudo apt-get update and then reinstall the one from Ubuntu repositories.

Once that is done and you are unable to reproduce the error.

Follow the steps in this tutorial (If you specifically need version 5.7):

https://www.digitalocean.com/community/tutorials/how-to-install-mysql-on-ubuntu-14-04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.