2

I want to install Ubuntu into my machine, but it won't boot properly no matter what I do. I tried every type of combinations: USB2 and USB3 ports, different flash drives, UEFI and CSM modes, Linux distros, USB utilities (Rufus, Universal USB creator, LiLi) and most of them yield the very same result. I want to install 16.04.1 to get rid of Windows for good.

Machine: This machine came with Windows 10 preinstalled. Changed to 8.1 and now I want to use Ubuntu.

  • Packard Bell ENTE69BH 2015 assembly, bought brand new in Feb 2016.
  • Intel Core i3-5005U (Broadwell) 2x2.00 GHZ, 4 threads
  • InsydeH2O rev 5.0 (BIOS version 1.25)
  • Intel HD 5500 integrated graphics (Mobile Generation V)
  • 1x4GB RAM (DDR3L-1600, memtest86+ errors 0)
  • Windows 8.1 x64 (CSM)

First of all. I suspect there is something wrong with my USB controller or even worse, my BIOS, because I get this kind of error when booting without pci=off flag (cannot use it, you'll see)...

The Live USB menu pops up, and the Try Ubuntu/Install Ubuntu/OEM install entries will always lead to this:

0000:00:14.0: can't derive routing for PCI INT A
0000:00:14.0: PCI INT A: no GSI

System hangs.

I managed to boot with pci=conf1, pci=conf2 and pci=off but then it dumps me at the initramfs prompt without being able to load anything into anywhere (no mounts, no storages) I am trying to get into Ubuntu to try and then install it.

Tried acpi=noirq. This is the result:

0000:00:14.0: PCI->APIC IRQ transform: INT A -> IRQ 21

System hangs.

On my other computers I could boot and install with zero issues, using the same image, stick and tool.

If I try to boot with the acpi=off or noapic flag then I get interrupt issues:

0000:00:14.0: sharing IRQ 7 with 0000:00:1c.1
0000:00:14.0: sharing IRQ 7 with 0000:00:1c.2
0000:00:14.0: sharing IRQ 7 with 0000:00:1c.3

System hangs.

lspci from Windows (external PCIutil command line tools x64):

00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
03:00.0 Network controller: Qualcomm Atheros Device 0042 (rev 30)

Please help me! I still have Windows available. If you need more info, I will be checking here often. Any workaround will help!

I already tried Ubuntu, Lubuntu and Xubuntu, all of them with the versions 14.04, 16.04, 16.04.1 and 16.10. The same result.

EDIT: It turns out that the InsydeH2O 1.25 BIOS had a buggy ACPI Table. Flashed 1.35 BIOS for my laptop and now I can boot any OS that I want.

  • FTR, CSM or Compatibility Support Module, is not used very often in AskUbuntu, where it is commonly referred to as "Legacy Mode". You might have more luck with a DVD rather than a USB. – WinEunuuchs2Unix Oct 4 '16 at 1:54
  • Thanks for responding. I would try that, but my laptop lacks a DVD drive. I tried with both modes, Legacy and UEFI. My Windows installation runs through the CSM. – Benyamin Ausensi Oct 4 '16 at 1:58
  • If your bios is set to Legacy mode for Windows then by all means use the same method for Ubuntu installation. Did you follow these instructions to create USB?: [ubuntu.com/download/desktop/create-a-usb-stick-on-windows] – WinEunuuchs2Unix Oct 4 '16 at 2:05
  • I already tried that. I remark I tried both modes, starting with Legacy. Also tried EFI because I wanted to try Ubuntu to check if everything was working, and then erase Windows from the drive. But anyways, in legacy mode I get the errors above without pci=off, and in EFI I get a black screen instead. With pci=off, both modes function but drop me at initramfs (possibly after starting that casper (kernel) they cannot handle my drive) Sorry for confusing you so much, but I am not very experienced with Linux in general – Benyamin Ausensi Oct 4 '16 at 2:10
  • Any boot parameters that can help me to work around this?? – Benyamin Ausensi Oct 4 '16 at 2:34
1

I have a different laptop Acer Aspire E5-573-P1NH also with "InsydeH20 Rev.5.0" system bios version 1.25. and I have the same problem. I have read here Ubuntu error message after GRUB " pci 0000:00:14:0: PCI INT A no GSI " that my laptops BIOS v1.37 will fix the problem but have not checked this yet.

This may be a general problem with early versions of this type of BIOS and you may be lucky and have a fixed version available. Have you updated your BIOS to its latest version?

Hope this helps.

  • Thank you my friend. I finally gathered up the courage to update the BIOS of my only laptop. Packard Bell makes it's machines from Acer so I thought that my machine would be compatible with the CRISIS Fn+Esc recovery method. I attempted to flash with this instead of ZRT_135 and the board did boot. Will test a live USB right now. – Benyamin Ausensi Jan 17 '18 at 2:51
  • Thanks for your suggestions! It works now, I can say that my EasyNote TE69BH is now happily running Xubuntu 16.04 dualbooted with Windows 10. – Benyamin Ausensi Jan 17 '18 at 4:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.