22

So I'm running VMware Workstation 12 Player on 16.04 host. And every guest i run complains that "No 3d support is available from the host" and "Hardware graphics acceleration is not available" "Accelerate 3D graphics is checked off in the player. I have AMD RX480 8gig GPU with amd drivers

sudo lspci -knn | grep -A2 VGA
02:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:67df] (rev c7)
    Subsystem: PC Partner Limited / Sapphire Technology Device [174b:e347]
    Kernel driver in use: amdgpu
glxinfo | grep direct
direct rendering: Yes
$ vmplayer &
Gtk-Message: Failed to load module "atk-bridge": /usr/lib/x86_64-linux-gnu/libatspi.so.0: undefined symbol: g_type_class_adjust_private_offset
Gtk-Message: Failed to load module "unity-gtk-module": libunity-gtk-module.so: cannot open shared object file: No such file or directory
(vmware-modconfig:4752): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
...repeats x20 ...
vmware-modconfig:4752): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
(vmware-modconfig:4752): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "atk-bridge": /usr/lib/x86_64-linux-gnu/libatspi.so.0: undefined symbol: g_type_class_adjust_private_offset
Gtk-Message: Failed to load module "unity-gtk-module": libunity-gtk-module.so: cannot open shared object file: No such file or directory
(vmplayer:4747): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
(vmplayer:4747): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
I/O warning : failed to load external entity "/etc/vmware/hostd/proxy.xml"
4
  • 3
    Check that you have OpenGL acceleration on your host glxinfo | grep Direct should output "Direct rendering: yes". There is also a suggestion from another site to try this<br/>Edit the file ~/.vmware/preferences and look for a line that starts with mks.gl.allowBlacklistedDrivers, if it is not present - you can add it into the file. This should be changed to mks.gl.allowBlacklistedDrivers = "TRUE" (note the double quotes around TRUE)<br/>If these don't work run vmware from the command line, watch the output in the console for any clues.
    – GrannySez
    Oct 3, 2016 at 23:13
  • @GrannySez edited
    – meccooll
    Oct 4, 2016 at 2:04
  • 1
    mks.gl.allowBlacklistedDrivers = "TRUE" did the trick thnx!! You can add it as an answer
    – meccooll
    Oct 5, 2016 at 2:50
  • 2
    @GrannySez That command should be glxinfo | grep -i Direct because the d is in lowercase in the output
    – Anwar
    Mar 24, 2018 at 13:10

1 Answer 1

44

[My setup: Ubuntu 16.10 64-bit Host (upgraded from 16.04) + VMware Workstation 12.5x + Windows 10 64-bit Guest]

I had the same two errors which you cite. What worked for me is:

vim .vmware/preferences

mks.gl.allowBlacklistedDrivers = "TRUE"
7
  • 3
    Thanks! It's unbelievable I had to come here for this information instead of finding it on the VMware website or in the documentation...
    – mzuther
    Mar 6, 2019 at 16:48
  • Worked like a charm on VMWare 15!
    – Siniša
    Mar 21, 2019 at 5:31
  • 2
    Thanks! It also worked for me in KDE Neon 5.17 with VMware Workstation 15 player. I have found an extended solution/explanation here: namhuy.net/227/…
    – call0fcode
    Oct 21, 2019 at 17:12
  • 2
    Works on Ubuntu 20.04 LTS, VMWare Workstation 15
    – Jimbo Alba
    May 14, 2020 at 10:55
  • 1
    Works on Ubuntu 22.04 Jammy and VMWare Workstation 17 ... It was on trouble following a Nvidia driver update ...
    – Antonio
    Oct 3, 2023 at 15:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .