Ubuntu 11.10 has faffed up on me, It wont let me get passed the login-screen ( i have been searching around online the last two days and none of the proposed solutions worked) as at this point I don't care to try to fix it

I have booted the liveusb and need access to my files so i can move them to an external drive, the issue is i cant move, for example, .thunderbird, as i don't have permission

so please, how can i get permission? as in how do i get to enter password so i can move my files

(please don't confuse what I am asking, as on other forums that i have googled, people keep saying that you are root in a livecd session, this completely misses the point, i need root privilege to move the files from the hard-drive, gksu nautilus doesn't give permission to move/copy files)


IIRC root is root wherever you're logging in from, be that the CD, another installation or whatever.

If you're having issues, on the CD just load a root instance of nautilus (Alt+F2, gksu nautilus) and carry on.

If your filesystem has suffered some damage it might be mounting in read-only mode. If you're trying to move things, this won't work. So for the purposes of your backup only try to copy things.

|improve this answer|||||
  • hi Oli, thank you for the reply, but no this doesnt work, and i also dont think the FS is damaged, only because it was a fresh install, it was an update that messed it up. anyway, you have answered the way i was trying to avoid, gksudo nautilus doesnt give permission for files that are on the HD which are password protected, so even though I am root on the live cd, i have not entered my passedword anywhere to have permission to move files or even copy files from the actual harddrive as ubuntu keeps reminding me. how can i enter a password to gain access? – Jayo Nov 27 '11 at 22:42
  • hang on, you could be right actually, i tried to copy a file that shouldnt be root protected, and it wouldn't copy, does this mean i could never recover those files – Jayo Nov 27 '11 at 22:50
  • 1
    its ok, i worked it out, i have to individually change the permissions in each file in the properties tab – Jayo Nov 27 '11 at 23:04

In the commandline, type in the following

gksudo nautilus

Press enter and a folder will open, and as long as you're within it, you have root access to all your documents- including the one's on the hard drive.


|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.