I have a HP pavilion dv4 4141US laptop running fresh ubuntu 11.10. This laptop has a broadcom 4313gn chipset for the network card. The network card is using the brcmsmac driver. Which, I heard else where on askUbuntu that its the best driver to be using for this card.

I can connect to my network, however I have extremely low network signal. Right now I am right in front of the router, and I only get 72%. If i go to the room directly behind the router's wall, i get no signal, where as with windows 7 I get a nice 70% percent.

UPDATE: I use WEP at home and an open wireless connection at work. Both have same result. Both are completely different routers. Also you G

What can i do?

  • I didnt find it necessary to blacklist, since my card has loaded the brcmsmac driver. As it says in network information. Thanks! – thegreyspot Nov 30 '11 at 15:39
  • Have you tried the other recommended driver wl some people say it works best for them than brcmsmac askubuntu.com/questions/75398/… – sagarchalise Dec 1 '11 at 9:26
  • I have really wanted to try this driver, but i never seem able to load it completely. After I run the rmmod commands and the modprobe, I just see the "wireless networks" area disappear from the network manager in the top bar. I also go into settings and activate the proprietary driver, but still, no wireless network options in the network manager. – thegreyspot Dec 1 '11 at 19:55

Bug Reporting

According to this there is a report of the similar kernel version as used by oneiric having the same issue...

It is probably worth experimenting with different kernels to see if this resolves your issue - see the possible solutions below.

You should file a kernel launchpad bug report so that the Canonical Kernel maintainers are aware of the issue - possibly they may backport a patch from the latest release candidate in a future kernel build.

When filing the bug-report, they will ask you to test the latest mainline kernel. To do this, following the instructions below.

to install a kernel

Navigate to this website and download the files that look like the following:

headers_amd64.deb, headers_all.deb & image_amd64.deb if using 64bit Ubuntu

headers_i386.deb, headers_all.deb & image_i386.deb if using 32bit Ubuntu

Install the packages downloaded using the terminal command:

sudo dpkg -i linux*.deb


When booting press SHIFT to display your GRUB - this screen lists your kernels - you can boot with any kernel listed including "older linux" option for old kernels.

Possible Solutions

  1. Look at the kernel mainline and choose a newer kernel - preferably one that has the oneiric name associated with it - however you could also try the very latest (but probably unstable) 2.6.32 release candidates.

  2. Looking closely at that bug-report, early in the thread the OP reported that his issue was due to a hidden SSID. Possibly you can check in your router settings whether you are using a visible SSID or a hidden SSID.

  3. Also, the OP reported that he didn't have his particular issue with the older kernel. You could also try that by downloading this from the launchpad mainline and installing this using the instructions above. Remember to booting into the older kernel by selecting it from GRUB.

Tidying up

If this doesn't workout for you - remove this kernel using my answer in this question

If the newer/older kernel works for you then you can use my answer here to "fix" the kernel i.e. to always boot into the newer/older kernel.


As we have discussed - trying all of the above, booting with the older kernel seems to provide you with the best solution.

  • Ok I just finished installing, but I see no difference. I think I will take your advice and file a bug report. – thegreyspot Dec 1 '11 at 19:56
  • That report you linked to seems exactly my issue. I am having problems following it though, due to the format of the site hahaha. Do you see it concluding in anyway? – thegreyspot Dec 1 '11 at 20:06
  • No I am talking about the link you shared: mail.gnome.org/archives/networkmanager-list/2011-August/… They seem to be discussing my exact problem but I cannot understand what they ended up deciding what the problem was or if there is a fix. thanks – thegreyspot Dec 1 '11 at 23:23
  • It seems that I am not using this new kernel after I reboot. Uname reports the same version 3.1,4-030104 – thegreyspot Dec 2 '11 at 21:40
  • 1
    Ahh! i missed the "older linux" option in grub. It seems to be much better now :) Is it safe to just set the default grub start up to the older kernel? Thank you so much for your help – thegreyspot Dec 2 '11 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.