I thought that my ATI driver was not running well so I wanted to re-instal it completely. I did:

sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon

and after a boot I wanted to intal the ATI driver BUT at the boot no more signal to my screen.

Since, every time I turn on my PC it gets to purple screen and then screen shuts down !

Note that:

  • Even if the screen is off, PC seems to be running almost well: I m still able to use my network to access data shared with NFS.
  • Using live USB I have no screen problem.
  • I tried to plug my screen on an alternative output but it did not work.
  • I tried CTRL+ALT+F1 while being on purple screen but it does not do anything, screen shut down anyway.
  • I m going to try the SHIFT thing and learn from blackscreen wiki...
  • 1
    FYI, you actually ended up uninstalling BOTH the AMD driver and the open source driver. – Uri Herrera Nov 28 '11 at 0:15
  • yes I though that my open source driver where still there. I will remember it !! – Boris Nov 28 '11 at 22:02

Unfortunately it appears you left out a few commands;

sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri fglrx-modaliases
sudo dpkg-reconfigure xserver-xorg

Your X server configuration likely lists no driver so it will not load properly. You may be able to recover by following the guide by effenburg on this Ubuntu Forums post

| improve this answer | |
  • yes I though that my open source driver was still there and I was on my way to run the install command just after reboot. But it appears that this was not a good idea, oups! Thank you for your link it helped me to solve the issue. – Boris Nov 28 '11 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.