0

Looked at similar topics such as high cpu usage - Eclipse does produce "an error occurred see log file" - see some of it below. Was working fine on 14.04.
I have tried the fix "--launcher .GTK_version 2" in the ini file but that did nothing. I am running Java 8 and all Java programs work fine.

!SESSION 2016-10-03 10:37:12.966 -----------------------------------------------
eclipse.buildId=debbuild
java.version=1.8.0_91
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  --launcher.GTK_version 2
Command-line arguments:  -os linux -ws gtk -arch x86_64 --launcher.GTK_version 2

!ENTRY org.eclipse.osgi 2 0 2016-10-03 10:37:13.778
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.778
!MESSAGE Bundle reference:file:plugins/org.eclipse.compare.core_3.5.200.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.compare.core 2 0 2016-10-03 10:37:13.778
!MESSAGE Missing imported package com.ibm.icu.text_3.6.1.
!SUBENTRY 2 org.eclipse.compare.core 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing imported package com.ibm.icu.util_3.6.1.
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.779
!MESSAGE Bundle reference:file:plugins/org.eclipse.ui.workbench_3.8.1.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.ui.workbench 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.779
!MESSAGE Bundle reference:file:plugins/org.eclipse.update.scheduler_3.2.400.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.update.scheduler 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.779
!MESSAGE Bundle reference:file:plugins/org.eclipse.equinox.p2.ui.sdk.scheduler_1.1.0.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing imported package com.ibm.icu.util_4.0.1.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.779
!MESSAGE Bundle reference:file:plugins/org.eclipse.help_3.6.0.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.help 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".
!SUBENTRY 2 org.eclipse.help 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing imported package com.ibm.icu.text_3.8.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.779
!MESSAGE Bundle reference:file:plugins/org.eclipse.equinox.p2.ui.sdk_1.0.200.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.779
!MESSAGE Bundle reference:file:plugins/org.eclipse.ui.net_1.2.101.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.ui.net 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.779
!MESSAGE Bundle reference:file:plugins/org.eclipse.equinox.p2.ui.importexport_1.0.1.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.779
!MESSAGE Bundle reference:file:plugins/org.eclipse.help.webapp_3.6.101.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.help.webapp 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing imported package com.ibm.icu.text_3.8.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.779
!MESSAGE Bundle reference:file:plugins/org.eclipse.equinox.p2.ui_2.2.0.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.779
!MESSAGE Bundle reference:file:plugins/org.eclipse.platform_3.8.1.dist/ was not resolved.
!SUBENTRY 2 org.eclipse.platform 2 0 2016-10-03 10:37:13.779
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.780
!MESSAGE Bundle reference:file:plugins/org.eclipse.ui_3.8.0.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.ui 2 0 2016-10-03 10:37:13.780
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.780
!MESSAGE Bundle reference:file:plugins/org.eclipse.ui.views.properties.tabbed_3.5.300.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.ui.views.properties.tabbed 2 0 2016-10-03 10:37:13.780
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.780
!MESSAGE Bundle reference:file:plugins/org.eclipse.update.ui_3.3.0.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.update.ui 2 0 2016-10-03 10:37:13.780
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".

!ENTRY org.eclipse.osgi 2 0 2016-10-03 10:37:13.889
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.889
!MESSAGE Bundle org.eclipse.compare_3.5.300.dist [22] was not resolved.
!SUBENTRY 2 org.eclipse.compare 2 0 2016-10-03 10:37:13.889
!MESSAGE Missing required bundle org.eclipse.ui_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2016-10-03 10:37:13.889
!MESSAGE Missing required bundle org.eclipse.ui.ide_[3.3.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2016-10-03 10:37:13.889
!MESSAGE Missing required bundle org.eclipse.ui.views_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2016-10-03 10:37:13.889
!MESSAGE Missing required bundle org.eclipse.ui.workbench.texteditor_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2016-10-03 10:37:13.889
!MESSAGE Missing required bundle org.eclipse.ui.editors_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2016-10-03 10:37:13.889
!MESSAGE Missing required bundle org.eclipse.compare.core_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.889
!MESSAGE Bundle org.eclipse.compare.core_3.5.200.dist [23] was not resolved.
!SUBENTRY 2 org.eclipse.compare.core 2 0 2016-10-03 10:37:13.889
!MESSAGE Missing imported package com.ibm.icu.text_3.6.1.
!SUBENTRY 2 org.eclipse.compare.core 2 0 2016-10-03 10:37:13.889
!MESSAGE Missing imported package com.ibm.icu.util_3.6.1.
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.889
!MESSAGE Bundle org.eclipse.debug.ui_3.8.1.dist [47] was not resolved.
!SUBENTRY 2 org.eclipse.debug.ui 2 0 2016-10-03 10:37:13.889
!MESSAGE Missing required bundle org.eclipse.ui_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.debug.ui 2 0 2016-10-03 10:37:13.889
!MESSAGE Missing required bundle org.eclipse.ui.console_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.debug.ui 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.help_[3.4.0,4.0.0).
!SUBENTRY 2 org.eclipse.debug.ui 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.ui.workbench.texteditor_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.debug.ui 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.ui.ide_[3.5.0,4.0.0).
!SUBENTRY 2 org.eclipse.debug.ui 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.ui.editors_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.890
!MESSAGE Bundle org.eclipse.equinox.p2.ui_2.2.0.dist [95] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.ui_3.6.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.equinox.security.ui_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.equinox.p2.ui 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.890
!MESSAGE Bundle org.eclipse.equinox.p2.ui.importexport_1.0.1.dist [96] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.equinox.p2.ui_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.ui_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.ui.dialogs_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.ui.model_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.ui.viewers_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.importexport 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.890
!MESSAGE Bundle org.eclipse.equinox.p2.ui.sdk_1.0.200.dist [97] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.ui_3.6.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.equinox.p2.ui_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing optionally imported package org.eclipse.compare_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing optionally imported package org.eclipse.compare.structuremergeviewer_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.5))(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.1)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-10-03 10:37:13.890
!MESSAGE Bundle org.eclipse.equinox.p2.ui.sdk.scheduler_1.1.0.dist [98] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.ui_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing required bundle org.eclipse.equinox.p2.ui_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing imported package com.ibm.icu.util_4.0.1.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.ui.actions_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk.scheduler 2 0 2016-10-03 10:37:13.890
!MESSAGE Missing imported package 
0

There are a couple of things you can do to address your version 3.8. First remove the installation that is failing. Apply a fresh install with:

$ apt remove --purge eclipse
$ apt update
$ apt upgrade
$ apt dist-upgrade
$ apt install eclipse

Start eclipse with this commandline:

$ eclipse --launcher.GTK_version 2

You can also consider installing the latest version of eclipse available from the Official Eclipse Website.

You can actually have both installed at the same time without a conflict. Just make a workspace for the new version by selecting the option prompt when starting it. Answer the prompt for workspace with something similar to ~/workspace-neon.

Now you can use Eclipse's import option and browse to your previous workspace and import the projects you want to bring over.

Eclipse is shipped for Linux in a tar format with all the binary files included. The install is as simple as making a directory for the installation, then running extracting the tar file there.

To run it just go to the directory and run:

$ ./eclipse  --launcher.GTK_version 2

A convenient system-wide location is:

/opt/eclipse/eclipse-neon

Installing the latest Eclipse Version

You can link the exec file to the search path with:

$ sudo ln -s /opt/eclipse/eclipse-neon/eclipse /usr/local/bin/eclipse-neon

Now you can start it with eclipse-neon from any where on the system without specifying a full pathname.

Having the latest version will give you an added benefit better support from the Eclipse community. Some of the problems of version 3.8 has been resolved in the current Eclipse version 4.6.0.

  • Tried the 1st solution - no success there - same error in log files. The second solution - install Neon works. Will transition to Neon Eclipse. I do have opencv applications that use cameras so we'll see how well things xfer over (but that's another topic for later if needed). I suspect we can close this out. – Softwar Oct 5 '16 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.