In Ubuntu 16.04 I had to reboot and after logging in there was no GUI, just the background color of my desktop and mouse. I could not open any applications except System Monitor. I tried to end a couple of processes related to unity in the hope that menu etc. would shop up again. No luck, so I did a shutdown with the power button.

After reboot, everything seemed to be OK, except that I couldn't switch workspace with shortcuts (Ctrl+Alt+Arrow keys) - so, that's my problem now.

I tried:

  • Changing the shortcuts in keyboard settings
  • unity --reset
  • gsettings reset-recursively (different stuff) link
  • reboot

Other shortcuts related aren't working either, like Super+Home to switch to Workspace 1. I can switch using Super+S. When I pull up the shortcut list holding Super down 2 sec. I can see that the shortcut for switching (Ctrl+Alt+Cursor Keys) are not mentioned... Other shortcuts seem to work. Using the mouse to snap a window to the maximum are not working either (double-click works).

Maybe I stopped something that didn't start again?

1 Answer 1


Found the answer myself using this guide: How To Reset Unity And Compiz In Ubuntu 14.04, 13.10 Or 13.04.

Installed dconf-tools:

sudo apt-get install dconf-tools

Did the reset:

dconf reset -f /org/compiz/

And restart Unity:

setsid unity

And then I rebooted just to be sure.

Finally, you need to re-enable workspaces after the reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.