2

I have 12.04 and I partially updated it from the update manager. It was showing me an option of update to 14.04 too. After the partial update I found, it removed my libreoffice and I can't open my files. It also removed the availability of update to 14.04 from the manager. I tried changing the source server from software centre but didn't work.

Now, after the shutdown, Ubuntu won't boot and leads to a tty1 login for a second before it hangs at 'system running in low graphics mode' error.

What should I do? I have certain data that wasn't backed up and I can't lose it!

  • 1
    1) Don't panic. 2) Buy an external HDD >= the capacity of your internal one. 3) Boot from a live DVD 4) Copy all the sub-folders of your /home/yourname folder onto the external HDD. 5) Re-install the latest LTS release (16.04.1 at this time), formatting the internal disk. – You'reAGitForNotUsingGit Oct 2 '16 at 21:08
  • 1
    This is a good lesson that you should back up everything at least monthly, and backup your most important files weekly, or even daily. – You'reAGitForNotUsingGit Oct 2 '16 at 21:10
  • I have booted from a live USB. And backed up important data. I wish to recover my old OS. For that I installed boot-repair. It worked to the point that it gives me an option to go to generic mode, recovery mode, previous versions, memory test etc. on booting. However, they don't really work. I'm still not able to log-in. It shows me 'running in low graphics mode' error. How can I retrieve my old desktop? – Rhea Oct 4 '16 at 16:51
  • Update: I have recovered my old desktop. Could you please tell me a way to update to 14.04 first (or directly to 16.04 will do too) so that I face no problem in booting and not lose my data? I don't wanna undergo any ordeal.. – Rhea Oct 4 '16 at 17:26
  • See, the thing is, if the upgrade only partially completed, I can guarantee you that you have broken packages. I'd really suggest you reinstall. I think you can reinstall while keeping your /home folder. See my answer. – You'reAGitForNotUsingGit Oct 4 '16 at 19:15
1

As per my comment, I think your install has broken packages due to the failed upgrade, so in this answer I will present a method where by you can re-install, and keep your /home folder. (Programs will have to be reinstalled though)

Warning! I take no responsibility if this fails and you lose your data because you failed to back it up!


Before you begin, run this command to find out your username:

whoami

Write the output down! (Also write down your password)


Now for reinstalling:

  1. Download the latest LTS Ubuntu ISO. In this case, that would be 16.04, unless you have an AMD graphics card and are using fglrx, in which case you should get 14.04

  2. Burn the ISO to a DVD, or use the included Startup Disk Creator program to make a live USB drive.

  3. Boot the install media you created in step #2

  4. Choose to install Ubuntu

  5. On the "installation type" screen, choose Something Else

  6. Select Ubuntu system partition, and set its mount point as /. Be sure to keep the same format type, the same size, and untick the "Format" checkbox (else all data on "/" will be deleted!)

  7. When you are asked to create your username and password, USE THE ONES YOU WROTE DOWN EARLIER!!! (Else loose your data)

  8. After the installation finishes, follow the prompts to shutdown, and remove the installation media when it tells you to.

  9. Reboot and cross your fingers.

| improve this answer | |
  • I tried what you said. I created a live USB and chose 'Install Ubuntu'. However it leads me to the following error: "This Dell Recovery Media can be used to restore the original factory software. It is recommended you back up all important data before running this tool. Error msg :"This Recovery Media only functions on Dell and Alienware Systems" Also, it disconnects from the wifi, not showing any listings to connect. I have checked all boot settings beforehand. – Rhea Oct 5 '16 at 14:48
  • 1
    @Rhea - If you got that, then you didn't download the official ISO. Download this: releases.ubuntu.com/16.04/ubuntu-16.04.1-desktop-amd64.iso – You'reAGitForNotUsingGit Oct 5 '16 at 21:35
  • I worked by changing the source from software centre for the update. It worked and updated the OS to 14.04. However, I'm stuck at the boot now. It loads perfectly but after I log in, the screen blacks out and shows the error: "starting light display manager stopping; send an event to indicate plymouth is up". I tried to fix it using live usb and boot repair. And also tried installing/updating grub. However, I'm stuck at the part where I'm supposed to Chroot for grub to work. Can you help me with this? – Rhea Oct 6 '16 at 12:11
  • @Rhea - So I'm confused - you did what I suggested in my answer or not? – You'reAGitForNotUsingGit Oct 7 '16 at 10:48
  • I'm sorry I didn't follow those steps because meanwhile I had updated to 14.04 through update manager. It updated, but after the default restart, I'm stuck at the login screen that shows me the error "starting light display manager stopping; send an event to indicate plymouth is up". It's stuck in a login loop. I've tried almost everything. I really don't know where the problem is! – Rhea Oct 7 '16 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.