1

Specifications

PC: Dell XPS all-in-one 2710
OS: Ubuntu 16.04

The sound from my speakers is not working by default until I install QasMixer or GNOME ALSA Mixer.

When I open gnome-alsamixer I find the speakers are not muted, and the headphones are muted. If I make the headphones unmuted, the speakers work, but I have to do that again every time I start up the computer.

Below is the output of lspci -nnk | grep -A Audio and aplay -l and pactl list sinks

linux@linux-XPS-One-2710:~$ lspci -nnk | grep -A Audio
grep: Audio: invalid context length argument  

linux@linux-XPS-One-2710:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3260 Analog [ALC3260 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

linux@linux-XPS-One-2710:~$ pactl list sinks
Sink #0
    State: RUNNING
    Name: alsa_output.pci-0000_00_1b.0.analog-stereo
    Description: Built-in Audio Analog Stereo
    Driver: module-alsa-card.c
    Sample Specification: s16le 2ch 44100Hz
    Channel Map: front-left,front-right
    Owner Module: 6
    Mute: no
    Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
            balance 0.00
    Base Volume: 63069 /  96% / -1.00 dB
    Monitor Source: alsa_output.pci-0000_00_1b.0.analog-stereo.monitor
    Latency: 50769 usec, configured 56000 usec
    Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
    Properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "ALC3260 Analog"
        alsa.id = "ALC3260 Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "0"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xf7c10000 irq 36"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1b.0"
        sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "1e20"
        device.product.name = "7 Series/C210 Series Chipset Family High Definition Audio Controller"
        device.form_factor = "internal"
        device.string = "front:0"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analog Stereo"
        device.description = "Built-in Audio Analog Stereo"
        alsa.mixer_name = "Realtek ALC3260"
        alsa.components = "HDA:10ec0275,1028054b,00100008 HDA:80862806,80860101,00100000"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    Ports:
        analog-output-speaker: Speakers (priority: 10000)
        analog-output-headphones: Headphones (priority: 9000, not available)
    Active Port: analog-output-speaker
    Formats:
        pcm
  • What's your question? – David Foerster Oct 5 '16 at 7:54
  • im sorry about that sir, i installed ubuntu 16.04 on my pc "Dell xps all in one 2710" but i have not sound from speakers, but i have from headphones only, what can i do? – Karam Oct 6 '16 at 18:52
  • You could do nothing about it and live with it but I doubt that's what you had in mind. Please clarify what you want to achieve! (see How do I ask a good question?) – David Foerster Oct 6 '16 at 20:38
  • 1
    @DavidFoerster What happened here was that despite the broken English the original question was clear (at least it was clear to me) until Karam edited it out the good parts 2 hours ago. Now I can't vote to reopen it until someone rolls back his edit of 2 hours ago to restore the lost information. Otherwise I still can't help Karam until he gets his question in order. – karel Oct 6 '16 at 23:09
  • 1
    when i open gnome-alsamixer i find the speakers not muted, and the headphones is muted ... if i made headphones unmuted the speakers works?! ... after restarting OS the alsamixer back to heaphones mute And so on – Karam Oct 7 '16 at 9:31
0

Praise of God i could solving the problem by installing "hda-jack-retask" - open the terminal and post: [ sudo apt-get install alsa-tools-gui ] - then post: [ hdajackretask ] in the gui of "jack retasking" i found "green Headphone" set as "headphone" i checked "override" and choose "internal speaker" then i pressed the button "apply now" then "install boot override" then reboot finally, the problem solved ... I'm happy now ... thanks for every one tried to help me ... thank you very much

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.