3

My laptop right now runs Ubuntu Kylin, and has no Windows on it after accidentally wiping it when I updated the Ubuntu version. I'm trying to access a SSD from Samsung that used to work fine with windows.There's an .exe file to activate it.. However, right now I can't seem to get the file to open. It opens briefly and then closes. I've tried installing exfat-utils which I read somewhere solved other people's problems, but still I'm having no relief to my issue. I've tried using Wine, but I'm unfamiliar and can't get that to operate properly either.

8
  • SSD or SD card? Quite different. If the latter, what size? exFAT support required only for +64GB. What file? A Windows executable does NOT work in Linux. Some Windows programs may run with Wine but not all. Please edit your question in a way it makes sense, i.e., provide actual information about your intended result.
    – user589808
    Oct 1 '16 at 23:52
  • It's an SSD. I'm trying to run this .exe so that I can use it as a portable HD. It has 1TB, but it won't run right now since I'm stuck with Ubuntu. Is it possible to somehow open this program so that I can use the files inside? I think the encryption technology might be making it more difficult.
    – Jared Y
    Oct 2 '16 at 0:13
  • If it's a Windows proprietary encryption software then you need Windows. Anyway, and again, what .exe? What software is that?
    – user589808
    Oct 2 '16 at 0:18
  • The .exe is just the app that comes installed with the Solid State Drive. When you plug it into the usb, it can be installed quite easily. However, the Linux OS is making it hard to access the files. The software seems to be part of Samsung's design to let users read files that are encrypted on their modern SSD's.
    – Jared Y
    Oct 2 '16 at 0:24
  • 1
    Yeah, I noticed that too, I was wondering if it were possible with all the creativity that goes on with Linux, hoping that there's the chance that someone's figured it out. I read some other posts, and someone on Fedora seemed to have gotten it. Mine starts, but quits before really working.
    – Jared Y
    Oct 2 '16 at 0:47
2

Samsung's proprietary software appears to be only for encryption. You won't be able to access any encrypted files on the drive from Linux since Samsung doesn't support that.

  • If the drive is encrypted and you don't have any (valuable) data on the drive or moved it somewhere else (temporarily), you can repartition, reformat and use the SSD in Linux without additional software.

  • If the drive is not encrypted you should be able to use it in Ubuntu right away or at least after installing the exfat-fuse package. If you can't, please edit your question or open a new question and include the output of lsusb, sudo lsblk -f and a screenshot of the drive as seen by GParted.

If you want to encrypt your data on Linux (or any operating system really), it's always better to opt for vendor-independent, non-proprietary solutions. Popular examples for disk encryption system on Linux are

  • LUKS (Linux and BSD with cryptsetup, Windows with LibreCrypt (beta), OS X only through Linux guest system) and

  • TrueCrypt/VeraCrypt (Linux, BSD with cryptsetup, Windows, OS X).

2
0

Sorry to hear that; my heart sank every time I read about people running into such or similar ordeal. I might be a little too late to help you but would like to share a little, hoping to help someone Googled here like I did. I have a T5 SSD from Samsung too. I started with DOSv3 and Windows XP was my last personal OS and then upgraded to Linux! For working purpose still stuck with Windows 10.

In short, what I would have done:

  1. Install Windows on:

    1a. Original PC or
    1b. Similar spec PC or
    1c. VirtualBox

  2. If an encryption key was saved/extracted previously, use that for recovery with the application program.

  3. No Encryption Key? Hopefully you can regenerate that from the program by using the same 'credential' you provided when you first encrypted the disk. That likely would work if using 1a. above.

  4. Couldn't get Windows OS, see if your SSD support Android or MacOS.

A longer read:

You need Windows because an .exe application runs on that OS. Firstly if the encryption method originally generated a key that you have saved/extracted into a file, your chances of recovering from it is higher, even on different hardware/platform. If not, hopefully you could still regenerate the same key from preferably the original PC - better chances; or a similar configured PC. This all depends on how vigorous the encryption method is. A side note btw, it's 20190918, Samsung SSD T3/T5 hardware encryption was discovered to have flaw in its implementation. If you have a hacker friend.

Have the key if one was generated. Reinstall Windows back to the same PC if possible, or else a similar hardware spec PC. A last resort to look at would be a virtual machine installation using VMware or VirtualBox.

Still another possible solution for SSD that support 'multi-platform' is to try using those other OSs if you have access to them. For example, the T5 can also be run on MacOS and Android. Search for 'Samsung Portable SSD' in Play store.

Just a little more about the encryption and the 'Encryption Key'. Strong encryption method's encryption key might be platform and system dependent. If the key was originally created with hardware IDs on CPUs/NICs and with Names like System 's or User's Name or any other combinations, re-creation of such key might need the original hardware and software setting. As this make the encryption less portable, some encryption algorithm allow the saving/exporting of such key for disaster recovery or system migration.

Lastly, it is not Linux's fault that Samsung didn't support at least some major distro like Ubuntu, Red Hat, Debian, SUSE ...

Hopefully this solve your problem and back up those important data to a Non-encrypted media, if possible. If you need encryption, perhaps look into an open source Linux-friendly yet multi-platform solution like Veracrypt.

0

if you have access to a windows, android or Mac system you can temporary disable the encryption of the use by using the Samsung tool. It's a matter of seconds. after disabling you have full access from linux. After using the ssd on linux, you can enable the encryption again on windows, macOS or android.

0

I found a workaround, not a solution. But it works fine for me.

  1. Connect the SSD to a USB-Hub with external power supply.
  2. Connect the USB-Hub to a windows computer
  3. Start the samsung SSD encryption tool in windows as usual. The encrypted partition will be visible.
  4. Disconnect the USB-Hub ONLY from the windows computer, leaving the SSD connected to the power provided by the hub.
  5. Connect the Hub to your Linux-System.
  6. Done - the encrypted partition is visible!
0

The encryption file (.exe) won't work on linux you have to do it on windows. I had this problem with my 1tb Sandisk portable SSD and it has a SecureAccess .exe file but, I couldn't get it to work on linux. Then, I tried wine and it still didn't work so I deleted the files. You can encrypt your files on the drive using linux and whenever you want to use them on another machine just decrypt them on your linux machine. Or you can lock the file and if you have administrator privileges on the other system unlock the file when you want to use it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.