1

I got a working desktop computer to put a drive in that was messed up by a chmod command.

I know my drive encryption and home folder encryption passwords which was added on this drive during installation of Ubuntu 14.04.

How do I decrypt and access home-folder-files from this drive?

The disk is encrypted using sda3_crypt

  • This depends which encryption you have used. LUKS, ecryptfs, EncFS, Truecrypt...? – Thomas Oct 1 '16 at 10:37
  • @Thomas It says sda3_crypt for the disk encryption. I don't know how the home folder is encrypted, but it is probably the default encryption method of Ubuntu home folders. – Delfil Oct 1 '16 at 11:05
  • You could try cryptsetup luksOpen /dev/sda3 mycryptdisk. You should be asked for the passphrase. If successful, you could mount it with mount /dev/mapper/mycryptdisk /mnt. – Thomas Oct 1 '16 at 11:09
  • Using sudo lsblk -o NAME,FSTYPE,SIZE,MOUNTPOINT,LABEL askubuntu.com/a/333604/601533 Result: pastebin.com/f1twj0jX sdb3 is the partition I want to access. With the cryptsetup line of Thomas, I get Device /dev/sda3 is not a valid LUKS device. Switching the position of /dev/sda3 and mycryptdisk I get: Device sdb3 doesn't exist or access denied. or Device crypto_LUKS doesn't exist or access denied. – Delfil Oct 5 '16 at 18:55
  • I tried opening and decrypting the partition using the graphical application Files, where all folder names are present as unreadable files. This may be because of the permission set on those files (see first line in the question). Is it safe to change these permissions? Screenshot: s10.postimg.org/654jw00dl/… – Delfil Oct 5 '16 at 19:08
0

I couldnt view the files due to a bad application of chmod. I fixed it by giving 777 rights to all files on the external disk. After that I could access my files using the application Files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.