4

I have been trying to upgrade from 14.04 to 16.04 for a few weeks with no success. As many others (e.g., here), I get an error message saying that Ubuntu "could not calculate the upgrade". I tried to inspect /var/log/dist-upgrade/apt.log to find out what packages were causing the issue, and got a list of approximately 800 broken packages:

Broken dpkg:amd64 Breaks on libapache2-mod-php5 [ amd64 ] < 5.5.9+dfsg-1ubuntu4.19 > ( httpd ) (< 5.6.4+dfsg-3~)
Broken perl-base:amd64 Breaks on perl-modules [ amd64 ] < 5.18.2-2ubuntu1.1 > ( perl ) (< 5.22.1~)
Broken findutils:amd64 Breaks on libpython3.4-minimal [ amd64 ] < 3.4.3-1ubuntu1~14.04.4 > ( python ) (< 3.4.4-2)
Broken libgnutls30:amd64 Conflicts on libnettle4 [ amd64 ] < 2.7.1-1ubuntu0.1 > ( libs )
Broken libgnutls30:amd64 Conflicts on libnettle4 [ i386 ] < 2.7.1-1ubuntu0.1 > ( libs )
Broken systemd:amd64 Conflicts on systemd-services [ amd64 ] < 204-5ubuntu20.19 > ( admin )
Broken systemd:amd64 Conflicts on systemd-services [ i386 ] < none > ( none )
Broken texlive-binaries:amd64 Breaks on luatex [ amd64 ] < 0.76.0-3ubuntu1 > ( tex ) (< 2014)
Broken libopencv-core2.4v5:amd64 Conflicts on libopencv-core2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 > ( libs )
Broken gnome-control-center:amd64 Breaks on libgnome-control-center1 [ amd64 ] < 1:3.6.3-0ubuntu56.1 > ( libs )
Broken xserver-xorg-core:amd64 Conflicts on xserver-xorg-video-glamoregl [ amd64 ] < 0.6.0+git1603170630.347ef4~gd~t > ( x11 )
Broken xserver-xorg-core:amd64 Conflicts on xserver-xorg-video-modesetting [ amd64 ] < 0.8.1-1build1 > ( x11 )
Broken unity-control-center-faces:amd64 Conflicts on gnome-control-center-shared-data [ amd64 ] < 1:3.6.3-0ubuntu56.1 > ( gnome )
Broken libaccount-plugin-generic-oauth:amd64 Conflicts on account-plugin-windows-live [ amd64 ] < 0.11+14.04.20140409.1-0ubuntu2 > ( gnome )
Broken ghc-doc:amd64 Breaks on libghc-transformers-doc [ amd64 ] < 0.3.0.0-5 > ( doc ) (< 0.3.0.0-6)
Broken libasprintf0v5:amd64 Breaks on libasprintf0c2 [ amd64 ] < 0.18.3.1-1ubuntu3 > ( libs )
Broken libopencv-imgproc2.4v5:amd64 Conflicts on libopencv-imgproc2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 > ( libs )

The list goes on forever, but it might already give an idea of what is going on. Anyway, I filed a bug report on the Ubuntu tracker, and was told that the problem was probably that I installed PPA packages that were incompatible with the new version. They suggested that I remove those packages with ppa-purge, specifically from the oibaf PPA:

sudo ppa-purge oibaf

However, I then get an error:

Updating packages lists
PPA to be removed: oibaf ppa
Warning:  Could not find package list for PPA: oibaf ppa

Any clue on how this issue could be solved?

  • First of all, ppa-purge doesn't work like that. You need to use the same name of the PPA when you add it. In this case "ppa:oibaf/graphics-drivers". Secondly, and after reverting the changes made by that PPA, you should fully upgrade within the current version by using "dist-upgrade". – user589808 Oct 1 '16 at 1:45
  • Better backup and install from scratch. Honestly, you're wasting a lot of time with something that has a simple, better and safer solution. – user589808 Oct 1 '16 at 1:47
  • @CelticWarrior "sudo ppa-purge ppa:oibaf/graphics-drivers" yields pretty much the same error message: "Warning: Could not find package list for PPA: oibaf graphics-drivers". – Arthur Azevedo De Amorim Oct 1 '16 at 1:50
  • Try sudo ppa-purge ppa:oibaf/ppa. It should work. – Emad Arshad Alam Oct 1 '16 at 4:40
  • @EmadArshadAlam No, it does not. – Arthur Azevedo De Amorim Oct 1 '16 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.