138

I'm using Ubuntu 11.10 with Unity and would like to switch between workspaces with a keyboard shortcut.

Is there any way to achieve this?

172

The shortcut Ctrl+Alt + arrow keys allows you to move in the workspaces.

You'll need to turn workspaces on if you're on 13.04+.

  • Under VMware (where Ctrl+Alt are the host OS escape keys) I'm unable to use left+right, but up+down work fine. Any ideas why that is? – jocull Sep 21 '16 at 14:04
  • 1
    @jocull: Press <kbd>HostKey</kbd> (and release. No key combination.) Then use <kbd>Ctrl</kbd>+<kbd>Alt</kbd>+↓/↑ as instructed. A good host key (=that has few collisions with typical Windows software) imho is right Ctrl. - If you stick with yours: try Ctrl-Alt (and release), then followed by the above. – Frank Nocke Oct 25 '16 at 1:34
  • 1
    As of Ubuntu 16.04 LTS, Super+S works, but not Ctrl+Alt+Left/Right – Fabián Sep 23 '17 at 21:00
  • @Fabián any idea why? I have 17.10 since weeks and it worked all well until today. For some reason it stopped working rght now. Any workaround to have this back? Workspace and this keyboard navigation is the only reason I keep Unity – dievardump Jul 2 '18 at 15:37
  • Answering to myself : as of 16.04, follow this answer (read the comment too) askubuntu.com/a/301595/787021 – dievardump Jul 2 '18 at 15:47
77
+50

In 13.04 workspaces are disabled by default. To enable them, open "Appearance" from the dash. It looks like this:

enter image description here

Switch to the "Behavior" tab and check "Enable workspaces".

enter image description here

After that the normal shortcuts will work:

Super+S for the workspace overview and Ctrl+Alt+Arrow Keys to switch between the individual workspaces.

  • 1
    +1 I was searching for that workspace overview shortcut – 7hi4g0 Mar 18 '14 at 13:28
39

In 12.04 and above, you can set shortcuts for this by launching keyboard from the Dash and choosing the shortcuts tab. Choose the Navigation option, then just change the various settings for Switch to workspace...

The Keyboard control panel, including the Shortcuts options

I use CTRL-ALT-F1 for workspace 1, CTRL-ALT-F2 for workspace 2 and so on.

This setting can also be changed in CompizConfig Settings Manager (not installed by default, so sudo apt-get install compizconfig-settings-manager if you want to use it). That program will also let you set things like moving to the next workspace when your mouse hits the edge of the screen - a setting I find too fiddly to use personally, but some might like.

  • With many workspaces, here is what I needed to go to. To get through time and time again with speed. – prosody-Gab Vereable Context Dec 11 '14 at 7:10
  • CTRL-ALT-F1 led me to a CLI and I didn't know how to get back to GUI from there, so I had to reboot. Advice to future readers: IF YOU DON'T KNOW HOW TO GET FROM TTY1 TO UNITY, DON'T HIT CTRL-ALT-F1 :D – thymaro Aug 10 '18 at 5:55
  • Just for the record, if you hit CTRL+ALT+F1 and get to tty1 you can go back to your desktop with CTRL+ALT+F7. I think it is this way in any linux distro – Santiago Sep 8 '18 at 19:43
  • Oddly enough, I thought this was true, but I recently installed Kubuntu 18.04 and it sets up its graphical environment on tty1, so hitting CTRL-ALT-F1 does nothing and you have to use tty2 through 6 instead! No idea why they changed what I considered to be something of a standard. – Scaine Nov 25 '18 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.