0

I just switched a PC to Ubuntu 16.04 and I'm getting some odd wireless network behaviour.

When I try to connect to my wireless, I have a brief connection followed by a disconnect. The thing is that every other device on my network also gets booted off (XBox360, Windows 10 laptop, 2 android phones). I can still see the network as available, but it won't establish a steady connection and my other devices won't connect at all.

I've tried to ping my IP address and I get one connection, followed by an endless series of messages saying the network could not be found, or that it could not connect.

Here are the results of my "lshw -c network"

*-network               
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: enp5s0
       version: 02
       serial: 00:25:64:8c:40:59
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:30 ioport:d800(size=256) memory:f7fff000-f7ffffff memory:cfff0000-cfffffff memory:f7fc0000-f7fdffff
  *-network DISABLED
       description: Wireless interface
       physical id: 1
       bus info: usb@2:5
       logical name: wlxc4e9840aae4f
       serial: c4:e9:84:0a:ae:4f
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192cu driverversion=4.4.0-31-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bgn

And here's the info on my "lspci -nnk | grep -iA2 -net"

05:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 02)
    Subsystem: Dell RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1028:02b7]
    Kernel driver in use: r8169
    Kernel modules: r8169

This may also be of interest:

  1. I'm connecting via a TP-Link (Model: TL-WN822N) Adapter;
  2. When I disconnect my wi-fi on my PC, my other devices re-connect to the network almost instantly (confirming for me that the problem is with Ubuntu);
  3. I can't connect via Ethernet because the only phone jack in my apartment is in another room and I don't have a cord long enough to reach the PC. My Ethernet cable is currently connected to my XBox, and there is no change in behaviour if my XBox is turned off);
  4. I tried using this wireless script, but nothing happens when I run it (regardless of whether the wireless is connected or not).

I apologize if this question has already been asked and answered, but I didn't see a similar situation where other household devices get booted off.

  • Before anything else, make sure you have the recommended wireless encryption settings: WPA2AES only! Not any WPA/WPA2 mixed mode and certainly not TKIP. After that you may also need another driver. The wriless script you mentioned is useful for diagnostics but it does nothing besides creating a file with the report at /home/your_username. Run it with the WiFi connected, find the resulting file, upload the contents to paste.ubuntu.com and edit your question with the given link. – user589808 Sep 30 '16 at 22:48
  • My wireless doesn't have a WPA2-AES option in the security drop down. Only WPA/WPA2 Personal and Enterprise, and a bunch of WEP and LEAP options. I'm looking into how to make this available and am speaking with my provider. Thanks for the response...will update when I hear more. – yannenkar Sep 30 '16 at 23:30
  • The settings I mentioned are at the router managing that wireless network. You cannot change from the clients. – user589808 Sep 30 '16 at 23:32
  • This solved the issue of regular disconnects and kicking other devices off the network. Thanks! – yannenkar Oct 1 '16 at 16:45
  • Nice. I'll turn it to an answer then. – user589808 Oct 1 '16 at 16:50
1

Make sure you have the recommended wireless encryption settings:

WPA2-AES only! Not any WPA/WPA2 mixed mode and certainly not TKIP.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.