0

I had a functioning ubuntu 14.04 system that I upgraded to 16.04 and everthing seemed to be working fine until I somehow changed my partition ( I think) from mbr to gtp.

My computer won't boot even to the grub menu so since my /home is on a seperate partition I decided to reinstall ubuntu 14.04 without reformatting /home to get system back (as I've done before) The problem is that after selecting something else and formatting / as ext4 and setting /home as ext4 but not formatting it, I hit install now and got the following error which I've never seen before.

" The partition table format in use on your disks normally requires you to create a separate partition for boot loader code. This partition should be marked for use as “Reserved BIOS boot area” and should be at least 1 MB in size. Note that this is not the same as a partition mounted on /boot. If you do not go back to the partitioning menu and correct this error, bootloader installation may fail later, although it may still be possible to install the boot loader to a partition."

Also there is small amounts of "free space" showing up between partitions in the install partition table.

Here is my current gparted gparted

and the installation type screen showing the free space and current device for bootloader installation installation type

Is there anything I can do to get back to a working ubuntu install, for instance if I shut down and boot to live CD again (to change from UEFI to BIOS somehow) have I wrecked everything by already formatting SDA5?

Edit /etc/fstab looks like

overlay / overlay rw 0 0

tmpfs /tmp tmpfs nosuid,nodev 0 0

/dev/sda6 swap swap defaults 0 0

Also. Output of gdisk /dev/sda is

GPT fdisk (gdisk) version 0.8.8

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT.

Could I get back to mbr using gdisk? I could if MBR was present but I'm not sure with protective.

  • Does Windows still boot? Please edit your question to show us what /etc/fstab looks like. Is your BIOS set to UEFI or Legacy/Compatible? Cheers, Al – heynnema Sep 30 '16 at 14:19
  • Windows does not boot. I edited the question to add that information and also the output of gdisk, thanks, Meabh – mmm Sep 30 '16 at 15:53
  • Also, I'm not sure if it's UEFI or Legacy and I'm too scared to restart the computer and check – mmm Sep 30 '16 at 16:04
  • You want it in UEFI mode. Also, what was in t he 359GiB unallocated partition? Also, see my answer, below. Cheers, Al – heynnema Sep 30 '16 at 16:12
  • Nothing was in it, but the extended partition what used to contain sda5,6 and 7 seems to have dissapeared, I presume that is why I have 1 MiB of unallocated between sda6 and sda7. I have added the boot flag as per your answer below and will now reinstall grub and ubuntu. Does it matter which order I install them in? Meabh – mmm Sep 30 '16 at 16:17
1

After discussions in the comments...

You do/did have a GPT disk. The GPT has a built in protective MBR for compatibility.

I just looks like the boot flag may have disappeared from sda1. Use gparted to add that flag back. If the fstab that you posted came from sda5, then it's wrong... reinstall Ubuntu into sda5, and tell it that you've got /home in sda7, and it should put in a valid fstab, and reinstall grub so that you can dual-boot again.

Report back. Cheers, Al

  • I did this and initially it booted to a black screen with a flashing prompt but then I went to BIOS and changed from Legacy to UEFI, and the system booted to ubuntu, files intact, worked perfectly. Should I reinstall grub so I can see the option of booting to windows again as it booted directly to ubuntu? – mmm Sep 30 '16 at 16:39
  • The BIOS should have been in UEFI mode when you installed Ubuntu. You want Windows and Ubuntu installed in the same mode. Try booting while holding down the LEFT SHIFT key, and that should bring up the GRUB menu, where you should be able to select which OS to boot. Cheers, Al – heynnema Sep 30 '16 at 16:46
  • It wasn't. Should I reinstall before proceeding? Thanks so much, Meabh – mmm Sep 30 '16 at 16:48
  • See if Windows boots first. Cheers, Al – heynnema Sep 30 '16 at 16:52
  • I didn't get the option to boot it – mmm Sep 30 '16 at 16:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.