2

I have been running Ubuntu on this laptop for over six years and never had this issue before. The wireless internet connection is unbearably slow. It dualboots with W10, which has fine connection speeds. I upgraded from 15.10 after which the problem started. I even did a fresh install trying to resolve it, but with no avail. So I'm running Ubuntu 16.04, 64bit.

*-network
            description: Wireless interface
            product: Centrino Wireless-N 1000 [Condor Peak]
            vendor: Intel Corporation
            physical id: 0
            bus info: pci@0000:04:00.0
            logical name: wlp4s0
            version: 00
            serial: 00:26:c7:d2:6b:74
            width: 64 bits
            clock: 33MHz
            capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
            configuration: broadcast=yes driver=iwlwifi driverversion=4.4.0-31-generic firmware=39.31.5.1 build 35138 ip=192.168.1.65 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
            resources: irq:35 memory:d3800000-d3801fff

rr1991@RR1991-MSi:~$ egrep -i 'fw|firm' /var/log/syslog 
Sep 29 13:24:48 RR1991-MSi kernel: [    0.280475] [Firmware Bug]: ACPI:      BIOS _OSI(Linux) query ignored
Sep 29 13:24:48 RR1991-MSi kernel: [    2.550406] psmouse serio1:   elantech: assuming hardware version 2 (with firmware version 0x040201)
Sep 29 13:24:48 RR1991-MSi kernel: [    2.867139] iwlwifi 0000:04:00.0: loaded firmware version 39.31.5.1 build 35138 op_mode iwldvm
Sep 29 13:24:48 RR1991-MSi NetworkManager[2491]: <info>  [1475148288.4032] manager[0x27121a0]: monitoring kernel firmware directory '/lib/firmware'.
Sep 29 13:24:56 RR1991-MSi dbus[2461]: [system] Activating service name='org.freedesktop.fwupd' (using servicehelper)
Sep 29 13:24:56 RR1991-MSi org.freedesktop.fwupd[2461]: (fwupd:3543): Fu-WARNING **: Failed to coldplug: UEFI firmware updating not supported
Sep 29 13:24:56 RR1991-MSi dbus[2461]: [system] Successfully activated service 'org.freedesktop.fwupd'
Sep 30 07:25:11 RR1991-MSi kernel: [    0.276052] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
Sep 30 07:25:11 RR1991-MSi kernel: [    2.692469] psmouse serio1: elantech: assuming hardware version 2 (with firmware version 0x040201)
Sep 30 07:25:11 RR1991-MSi kernel: [    3.742888] iwlwifi 0000:04:00.0:  loaded firmware version 39.31.5.1 build 35138 op_mode iwldvm
Sep 30 07:25:11 RR1991-MSi NetworkManager[2472]: <info>  [1475213111.1840] manager[0x1fd01a0]: monitoring kernel firmware directory '/lib/firmware'.
Sep 30 07:25:23 RR1991-MSi dbus[2451]: [system] Activating service name='org.freedesktop.fwupd' (using servicehelper)
Sep 30 07:25:25 RR1991-MSi org.freedesktop.fwupd[2451]: (fwupd:3529): Fu-WARNING **: Failed to coldplug: UEFI firmware updating not supported
Sep 30 07:25:25 RR1991-MSi dbus[2451]: [system] Successfully activated service 'org.freedesktop.fwupd'
Sep 30 07:49:13 RR1991-MSi kernel: [ 1448.379992] [Firmware Bug]: battery: (dis)charge rate invalid.
rr1991@RR1991-MSi:~$ dmesg | egrep 'iwl|[F]irm'
[    0.276052] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[    3.736407] iwlwifi 0000:04:00.0: can't disable ASPM; OS doesn't have ASPM control
[    3.742888] iwlwifi 0000:04:00.0: loaded firmware version 39.31.5.1 build 35138 op_mode iwldvm
[    3.817768] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEBUG disabled
[    3.817777] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[    3.817782] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[    3.817789] iwlwifi 0000:04:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[    3.817955] iwlwifi 0000:04:00.0: L1 Enabled - LTR Disabled
[    3.855334] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[    4.512147] iwlwifi 0000:04:00.0 wlp4s0: renamed from wlan0
[    5.456901] iwlwifi 0000:04:00.0: L1 Enabled - LTR Disabled
[    5.464316] iwlwifi 0000:04:00.0: L1 Enabled - LTR Disabled
[    5.464417] iwlwifi 0000:04:00.0: Radio type=0x0-0x0-0x3
[    5.497820] iwlwifi 0000:04:00.0: L1 Enabled - LTR Disabled
[    5.505207] iwlwifi 0000:04:00.0: L1 Enabled - LTR Disabled
[    5.505303] iwlwifi 0000:04:00.0: Radio type=0x0-0x0-0x3
[ 1448.379992] [Firmware Bug]: battery: (dis)charge rate invalid.
  • I'm sorry that I can't help you, but I can say that I'm having the exact same problem with my Centrino Wireless-N 1000 on 16.04.1, running "4.4.0-38-generic #57-Ubuntu SMP Tue Sep 6 15:42:33 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux" . – Zyberzero Oct 10 '16 at 20:23
1

Solved for me by setting the WiFi router (or AP) to use WPA2-PSK only with AES encryption.

Ubuntu 16.04.01 on 4.4.0-59-generic

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.