6

How can I fix this issue?

mona@pascal:~$ sudo apt-get update
Ign file:  InRelease
Get:1 file:  Release.gpg [181 B]                                               
Get:2 file:  Release [196 B]                                                   
Ign file:  Translation-en_US                                                   
Ign file:  Translation-en                                                      
Hit http://storage.googleapis.com stable InRelease                             
Hit http://storage.googleapis.com stable/jdk1.8 amd64 Packages                 
Ign http://us.archive.ubuntu.com trusty InRelease                              
Get:3 http://us.archive.ubuntu.com trusty-updates InRelease [65.9 kB]          
Hit http://ppa.launchpad.net trusty InRelease                                  
Get:4 http://security.ubuntu.com trusty-security InRelease [65.9 kB]           
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Get:5 http://us.archive.ubuntu.com trusty-backports InRelease [65.9 kB]        
Ign http://developer.download.nvidia.com  InRelease                            
Get:6 http://developer.download.nvidia.com  Release.gpg [819 B]                
Hit http://developer.download.nvidia.com  Release                              
Ign http://developer.download.nvidia.com  Release                              
Hit http://us.archive.ubuntu.com trusty Release.gpg                            
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Get:7 http://us.archive.ubuntu.com trusty-updates/main Sources [383 kB]        
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Ign http://storage.googleapis.com stable/jdk1.8 Translation-en_US              
Get:8 http://security.ubuntu.com trusty-security/main Sources [120 kB]         
Ign http://developer.download.nvidia.com  Packages/DiffIndex                   
Ign http://storage.googleapis.com stable/jdk1.8 Translation-en                 
Get:9 http://us.archive.ubuntu.com trusty-updates/restricted Sources [5,360 B] 
Get:10 http://us.archive.ubuntu.com trusty-updates/universe Sources [166 kB]   
Get:11 http://security.ubuntu.com trusty-security/restricted Sources [4,064 B] 
Get:12 http://security.ubuntu.com trusty-security/universe Sources [43.6 kB]   
Get:13 http://us.archive.ubuntu.com trusty-updates/multiverse Sources [7,520 B]
Get:14 http://security.ubuntu.com trusty-security/multiverse Sources [3,190 B] 
Get:15 http://us.archive.ubuntu.com trusty-updates/main amd64 Packages [901 kB]
Get:16 http://security.ubuntu.com trusty-security/main amd64 Packages [531 kB] 
Get:17 http://security.ubuntu.com trusty-security/restricted amd64 Packages [13.0 kB]
Get:18 http://security.ubuntu.com trusty-security/universe amd64 Packages [138 kB]
Get:19 http://us.archive.ubuntu.com trusty-updates/restricted amd64 Packages [15.9 kB]
Get:20 http://us.archive.ubuntu.com trusty-updates/universe amd64 Packages [376 kB]
Get:21 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [5,198 B]
Get:22 http://security.ubuntu.com trusty-security/main i386 Packages [493 kB]  
Get:23 http://us.archive.ubuntu.com trusty-updates/multiverse amd64 Packages [15.0 kB]
Get:24 http://us.archive.ubuntu.com trusty-updates/main i386 Packages [861 kB] 
Get:25 http://security.ubuntu.com trusty-security/restricted i386 Packages [12.7 kB]
Get:26 http://security.ubuntu.com trusty-security/universe i386 Packages [138 kB]
Hit http://developer.download.nvidia.com  Packages                             
Get:27 http://security.ubuntu.com trusty-security/multiverse i386 Packages [5,339 B]
Get:28 http://us.archive.ubuntu.com trusty-updates/restricted i386 Packages [15.6 kB]
Get:29 http://us.archive.ubuntu.com trusty-updates/universe i386 Packages [377 kB]
Ign http://developer.download.nvidia.com  Translation-en_US                    
Hit http://security.ubuntu.com trusty-security/main Translation-en             
Hit http://security.ubuntu.com trusty-security/multiverse Translation-en       
Hit http://security.ubuntu.com trusty-security/restricted Translation-en       
Ign http://developer.download.nvidia.com  Translation-en                       
Get:30 http://us.archive.ubuntu.com trusty-updates/multiverse i386 Packages [15.5 kB]
Hit http://security.ubuntu.com trusty-security/universe Translation-en         
Hit http://us.archive.ubuntu.com trusty-updates/main Translation-en       
Hit http://us.archive.ubuntu.com trusty-updates/multiverse Translation-en   
Hit http://us.archive.ubuntu.com trusty-updates/restricted Translation-en
Hit http://us.archive.ubuntu.com trusty-updates/universe Translation-en
Get:31 http://us.archive.ubuntu.com trusty-backports/main Sources [9,626 B]
Get:32 http://us.archive.ubuntu.com trusty-backports/restricted Sources [28 B]
Get:33 http://us.archive.ubuntu.com trusty-backports/universe Sources [35.2 kB]
Get:34 http://us.archive.ubuntu.com trusty-backports/multiverse Sources [1,898 B]
Get:35 http://us.archive.ubuntu.com trusty-backports/main amd64 Packages [13.3 kB]
Get:36 http://us.archive.ubuntu.com trusty-backports/restricted amd64 Packages [28 B]
Get:37 http://us.archive.ubuntu.com trusty-backports/universe amd64 Packages [43.2 kB]
Get:38 http://us.archive.ubuntu.com trusty-backports/multiverse amd64 Packages [1,571 B]
Get:39 http://us.archive.ubuntu.com trusty-backports/main i386 Packages [13.3 kB]
Get:40 http://us.archive.ubuntu.com trusty-backports/restricted i386 Packages [28 B]
Get:41 http://us.archive.ubuntu.com trusty-backports/universe i386 Packages [43.2 kB]
Get:42 http://us.archive.ubuntu.com trusty-backports/multiverse i386 Packages [1,552 B]
Hit http://us.archive.ubuntu.com trusty-backports/main Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/multiverse Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/restricted Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/universe Translation-en
Hit http://us.archive.ubuntu.com trusty Release   
Hit http://us.archive.ubuntu.com trusty/main Sources
Hit http://us.archive.ubuntu.com trusty/restricted Sources
Hit http://us.archive.ubuntu.com trusty/universe Sources
Hit http://us.archive.ubuntu.com trusty/multiverse Sources
Hit http://us.archive.ubuntu.com trusty/main amd64 Packages
Hit http://us.archive.ubuntu.com trusty/restricted amd64 Packages
Hit http://us.archive.ubuntu.com trusty/universe amd64 Packages
Hit http://us.archive.ubuntu.com trusty/multiverse amd64 Packages
Hit http://us.archive.ubuntu.com trusty/main i386 Packages
Hit http://us.archive.ubuntu.com trusty/restricted i386 Packages
Hit http://us.archive.ubuntu.com trusty/universe i386 Packages
Hit http://us.archive.ubuntu.com trusty/multiverse i386 Packages
Hit http://us.archive.ubuntu.com trusty/main Translation-en
Hit http://us.archive.ubuntu.com trusty/multiverse Translation-en
Hit http://us.archive.ubuntu.com trusty/restricted Translation-en
Hit http://us.archive.ubuntu.com trusty/universe Translation-en
Ign http://us.archive.ubuntu.com trusty/main Translation-en_US                 
Ign http://us.archive.ubuntu.com trusty/multiverse Translation-en_US           
Ign http://us.archive.ubuntu.com trusty/restricted Translation-en_US           
Ign http://us.archive.ubuntu.com trusty/universe Translation-en_US             
Fetched 5,007 kB in 7s (679 kB/s)                                              
Reading package lists... Done
W: GPG error: http://developer.download.nvidia.com  Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F60F4B3D7FA2AF80

and then I used this method here: https://chrisjean.com/fix-apt-get-update-the-following-signatures-couldnt-be-verified-because-the-public-key-is-not-available/

mona@pascal:~$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-key F60F4B3D7FA2AF80
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.TwDO5GWCyw --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/webupd8team-java.gpg --keyserver keyserver.ubuntu.com --recv-key F60F4B3D7FA2AF80
gpg: requesting key 7FA2AF80 from hkp server keyserver.ubuntu.com
gpgkeys: key F60F4B3D7FA2AF80 not found on keyserver
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

I also used another solution provided on web however still get the same error:

mona@pascal:~$ sudo apt-key del F60F4B3D7FA2AF80
OK

and:

mona@pascal:~$ gpg --keyserver hkp://keyserver.ubuntu.com --search-keys F60F4B3D7FA2AF80
gpg: directory `/home/mona/.gnupg' created
gpg: new configuration file `/home/mona/.gnupg/gpg.conf' created
gpg: WARNING: options in `/home/mona/.gnupg/gpg.conf' are not yet active during this run
gpg: keyring `/home/mona/.gnupg/secring.gpg' created
gpg: keyring `/home/mona/.gnupg/pubring.gpg' created
gpg: searching for "F60F4B3D7FA2AF80" from hkp server keyserver.ubuntu.com
gpg: key "F60F4B3D7FA2AF80" not found on keyserver

I can't also export it

mona@pascal:~$ gpg -a --export F60F4B3D7FA2AF80
gpg: WARNING: nothing exported
22

The solution is:

wget -qO - https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/7fa2af80.pub | sudo apt-key add -

as documented here: https://developer.nvidia.com/cuda-downloads -> Linux -> x86_64 -> Ubuntu -> 18.04 -> deb (network)

  • 3
    I would link to where you got this, so there's an official source (please don't rely on my comment for the source link) – Thomas Ward Sep 30 '16 at 12:13
  • @ThomasWard source added to the original answer – Simon Warta Mar 3 at 18:23
1

Try the following commands which worked for me:

curl -sL "http://keyserver.ubuntu.com/pks/lookup?op=get&search=0xF60F4B3D7FA2AF80" | sudo apt-key add -

sudo apt-get update
  • 1
    It would have to be ... | sudo apt-key add -, no? You need to add - as "file name" to read the key from, so that it reads from standard input. – Byte Commander May 4 at 16:36
  • Thanks for pointing out. Added now. – Rajneesh Aggarwal May 6 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.