1

I'm using a software AT89S52 ISP programmer in windows to uplaod hex files to my microcontroller with ARDUINO as ISP.I can't find any software to do the same task using UBUNTU(I'm using XUBUNTU 16.04). I've already tried the same app using WINE, but it doesn't recognize my uC.I've configured the serial port with wine already(sn -s /dev/ttyUSB0 ....). I'm following this tutorial : http://www.instructables.com/id/ARDUINO-AS-A-8051-PROGRAMMER/?ALLSTEPS Is there any app which can serve the purpose or is there any way WINE can be configured to work with the same app?

  • I'd also add that Wine unfortunately doesn't support USB. Last time it seems it was discussed here but since it didn't move much. – Hi-Angel Sep 29 '16 at 18:56
  • will it work over serial port(rs232, i think)? – Abinash Dash Oct 5 '16 at 18:47
  • Yeah, serial ports should be fine. You may probably need to create a symlink in ~/.wine/dosdevices to the serial port, i.e. /dev/ttySx (the exact device name you can find in dmesg | grep tty). But may be nowadays Wine itself creates the link, last time I did use it in Wine was two years ago. – Hi-Angel Oct 5 '16 at 19:54
1

I have used ExtremeBurner (built by extremeelectronics.co.in) on Windows and it worked perfectly fine. A linux version for it has been released. Refer this site

  • The site says it is for AVR . Will it work for AT89S52 uC?Have you tested it with the above uC? – Abinash Dash Sep 30 '16 at 7:05
  • @AbinashDash - Yes, this document at extremeelectronics.co.in/burner51/tutorial1.pdf says that AT89S52 is compatible. No, I haven't used it on AT89S52 - used it only for Atmega uCs. – QMrules Oct 1 '16 at 11:48
  • i'm unable to install wxgtk. Shows this error: "./avrprog: error while loading shared libraries: libwx_gtk2u_richtext-2.8.so.0: cannot open shared object file: No such file or directory" Any help ? – Abinash Dash Oct 4 '16 at 20:08
0

I found a github project which might be helpful.
Note: I've not tried it myself. I added this answer so that future readers might find this helpful Because compiling Extreme Burner from source gave error,which I couldn't solve(and gave up).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.