0

I have a Lenovo desktop, and have freshly installed Ubuntu 16.04. In the network manager I connect to my wifi, put in the password and the connection is established.

However, when I open Firefox or "Browser" it says unable to connect. In the terminal I "ping http://www.yahoo.com" and it says "unknown host".

Things I've also tried: Sudo service NetworkManager restart

Deleting the "mywifiname" file in /etc/NetworkManager/system-connection

Also when I try to connect to my hotspot it connects and there is internet. And when I shut down and plug in tails in the same computer there is internet with the same "mywifiname".

Any help will be much appreciated. Thanks

  • edit your post and add output from ifconfig -a netstat -rn and ping 8.8.8.8 – meccooll Sep 30 '16 at 8:35
  • (I couldn't get my question to keep my edit & I can't get this comment to style so.. here is a titanpad) titanpad.com/Y21Fxha3Xx – kek Oct 3 '16 at 3:34
  • 10.19.239.58 Mask:255.0.0.0 is valid but a crazy subnet is it correct? Are you getting it via DHCP? Can you also post your cat /etc/network/interfaces and see if you can ping 10.128.128.128 your default gateway – meccooll Oct 3 '16 at 8:45
  • Update: I reinstalled the same is to see if I could fix it but no. Also here is your output... cat /etc/network/interfaces \n #interfaces(5) file used by ifup(8) and ifdown(8) \n autolo \n iface lo inet loopback \n and finally ping 10.128.128.128 \n PING 10.128.128.128 (10.128.128.128) 56(84) bytes of data. \n and then it's just never returns to $ I have to ^c to get out – kek Oct 3 '16 at 19:52
  • Well there's your problem you can't even get to your default gateway. I can't imagine a router giving out 10.0.0.0/8 network!?! Once connected try sudo dhclient -v -r wlp4s0 and then sudo dhclient -v wlp4s0 post outputs and ifconfig -a and netstat -rn – meccooll Oct 7 '16 at 21:58
0

Update: I tried to use other OS like Xubuntu. And by that I mean I had the live CD and then "tried Xubuntu" to see if the connection would work and it didn't I also messed with a few settings in my BIOS and now when I connect to my wifi and my browser connects to the Google main page but nothing else and when I ping 8.8.8.8 it doesn't output anything different

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.