7

Ubuntu 16.04 LTS fresh install, on a Gigabyte GA-F2A88X-D3H Rev 3 motherboard.

  • Keyboard and mouse work fine when I have nothing in my USB 3 hub.
  • If I connect USB 2 flash drives in the hub, no problems.
  • If I connect a USB 3 flash or hard drive, all USB's become unresponsive, and cannot use Keyboard or mouse until I unplug it.

Where do I start to find the problem?

Thanks!

  • 1
    Do not know if this model is similar enough, but have seen other Gigabyte boards needing IOMMU in UEFI changes and the boot parameter iommu=soft [SOLVED] GA-970A-DS3P revision 1 no usb 3.0 ubuntuforums.org/showthread.php?t=2188370 – oldfred Oct 6 '16 at 15:47
  • 1
    That was it. You want to put that as an answer and I will credit it to you! – JonYork Oct 6 '16 at 17:43
7
+50

Do not know if this model is similar enough, but have seen other Gigabyte boards needing IOMMU in UEFI changes and the boot parameter iommu=soft

GIGABYTE GA-970A-DS3 motherboard not working with 64 bit kernel - IOMMU GRUB_CMDLINE_LINUX="iommu=soft"

https://ubuntuforums.org/showthread.php?t=2188370

Similar issues:

http://ubuntuforums.org/showthread.php?t=2111223&page=5

http://ubuntuforums.org/showthread.php?t=2292025

| improve this answer | |
2

Does your USB flash drive have an activity LED? Is it flashing rapidly when you plug it in? If you do not have an activity LED, run

sudo apt-get install dstat

then run

dstat

Look at your CPU and Disk usage, and see what is using up your resources.

Also keep in mind that dstat will run until you tell it to stop, so remember to CTRL-Z when you're done.

Dstat can still be helpful even if you DO have an LED to look at because it will also display your CPU, Network, and other resources. Which may be helpful in solving your issue.

| improve this answer | |
  • I ran Dstat. So, it's not the CPU or anything going crazy, I guess it is that my USB mouse and keyboard aren't happy when I plug it in as my mouse tracking is all over the place and choppy and there is a long delay/dropped characters with my keyboard. Any other suggestions? – JonYork Sep 29 '16 at 22:16
0

I have same motherboard. People suggested to do other thing:

In the BIOS:

  • Enable XHCI Handoff
  • Disable EHCI Handoff
  • Enable IOMMU

Kernel command line additions:

amd_iommu=on iommu=pt

Works fine for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.