1

I installed Skype using Ubuntu Software Center. When I logged in to Skype, it was automatically closed. I tried to remove and reinstall it but the problem is still there. How to fix it?

Update:

Log output after login.

hieund@hieund:/etc$ skype
Fatal: ASSERT: "interface->childCount() == children.count()" in file adaptor.cpp, line 200
Aborted
hieund@hieund:/etc$ 
  • Try to start it via terminal, when it is closed you can see some error output. – heartsmagic Nov 27 '11 at 8:40
  • where is it located? what command to start please? – emeraldhieu Nov 27 '11 at 8:42
  • 2
    Open a terminal (ctrl+alt+t) and just give the command: skype Upate your question with your output. And please give more info beside that output. ie, your Ubuntu version, your OS architecture (32bit or 64bit), your Skype version, etc. – heartsmagic Nov 27 '11 at 8:51
  • Shot in the dark, but.. any use? askubuntu.com/questions/45278/skype-2-2-0-25-keeps-going-off – Caesium Nov 27 '11 at 10:11
  • 1
    Ok. Worth posting info like that in the original question, always useful to know what you've tried so we don't post useless info :) – Caesium Nov 27 '11 at 10:30
3

Your error message leads me to this Ubuntu bug via Google..

https://bugs.launchpad.net/ubuntu/+source/qt-at-spi/+bug/890240

I'm surprised it hasn't gotten more attention if it is affecting Skype.. it may help if you chime in with your experience :)

1

Try this one.

http://www.filchiprogrammer.com/blog/2011/10/30/skype-issue-assert-interface-childcount-children-count/

I googled this for a solution and by just typing,

export QT_ACCESSIBILITY=0

fixes the problem.

Hope this helps to anyone setting up skype in Ubuntu 11.10.

Works fine for me

1

Skype 4.3 no longer supported on 32 bit, so microsoft kills it when you log in.(Silly). Solution: make skype a "higher" version: sudo sed -i 's/4.3.0.37/8.3.0.37/' /usr/bin/skype It replaces the version number in the binary for a higher one to work around the forced incompatibility. Make sure that you have the same version 4.3.0.37 by calling skype --version or update the command accordingly. Thanks to YuriyKuzin.

  • oh that is too funny... only needed this on my 32-bit system. my 64-bit system seems to work fine without it. – Jayen Dec 12 '17 at 23:11
0

Well, actually, the only thing that worked for me on Ubuntu 10.04 after trying to apply the advice of I don't know how many people, was to go to sound device configuration right after starting Skype and make a test call before any connected contact appeared on the screen (you have to be fast!!).

From there on, I can suspend the test call without even waiting for the lady to speak, and Skype keeps working. I found this solution merely by accident.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.