2

Background:

I've been using Linux since 1996, so I have attempted numerous troubleshooting steps to solve this issue, albeit a relatively minor one. The computer in question has a fresh install of Ubuntu GNOME 16.04.1. Hardware specs do not seem to be relevant, but are available should you require them.

Issue:

When I first installed the system, I used the GNOME "Software" app to install numerous programs (Stellarium, Inkscape, etc.) without issue. As soon as I would click "Install" I would be prompted to authenticate, and the app would immediately download and install. After installing numerous pieces of software (including things installed with "apt install" such as htop, tree, etc.), I went back to the "Software" app to install another program. This time, when clicking "Install", the status changes to "Pending" and I am never prompted to enter credentials. After several troubleshooting steps, including removing the "gnome-software" directory from ~/.local/share/applications and ~/.cache, I decided to run "gnome-software" from the terminal. Oh, and yes, I have tried turning it off and back on again. :)

Initially, I was receiving the following error:

(gnome-software:3126): Gs-WARNING **: Failed to create permission org.freedesktop.packagekit.trigger-offline-update: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.packagekit.trigger-offline-update is not registered

Upon purging and reinstalling "gnome-software" (apt purge gnome-software, apt autoremove, apt install gnome-software") that error went away. Running it from the terminal now displays no errors or warnings, and immediately launches the app; however, the problem still persists. Any app I attempt to install gets stuck in "Pending" and I am never prompted for credentials.

I did find an Ask Ubuntu thread similar to this: gnome-software on Ubuntu 16.04 doesn't work

I've tried everything mentioned therein, but nothing seems to work.

Any ideas?

  • This seems to be popping up quite a bit today askubuntu.com/questions/831091/… but that answer is not great. Some things to try, change your server in software and updates perhaps some are down? Run sudo apt dist-upgrade to update all packages. That is all I have for now, in the mean time, you could use synaptic to install your software from gui sudo apt install synaptic, it is not a fix by any means but at least you can install software. You should report this here launchpad.net/gnome-software as a bug. – Mark Kirby Sep 29 '16 at 13:20
3

While I have seen many proposed solutions to this issue, none of them solved it for me. It turns out that the problem was, strangely enough, with my network configuration. I had manually edited /etc/network/interfaces and set a static IP address, DNS servers, and a DNS search domain. I removed the manual configuration, rebooted, and let NetworkManager handle the connection. GNOME Software began immediately working, and I have had no problems since. It's important to note that I had correctly set the manual configuration, and had no issues whatsoever with the exception of the Software app.

  • This worked for me too, and is probably because GNOME Software is querying NetworkManager (via dbus?) as to whether the network is up before it will attempt installing packages. Since NetworkManager knows nothing about the interfaces which are configured via /etc/network/interfaces it can't say the network is up... – David Gardner Sep 12 '18 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy