0

there is a problem with the Ubuntu-Software center which i tried to find out the source for a 2 weeks now. Here is the setup/facts of the system in our organization:

  • Ubuntu 14.04 LTS is used for normal Desktop PCs
  • Installation is per PXE with preseed and autoconfiguration using Foreman and Puppet.
  • Centralized Network Storage is allocated for each User within the org if needed.
  • We maintain a clone of the Ubuntu Repository as well as our own apps/softwares.

This setup functions flawlessly in Ubuntu 14.04 but the problem arises when the Operating System installed is Ubuntu 16.04. The policykit are present in such a manner that the user logged-in is allowed to install softwares through the Ubuntu-Software Center. However, when installing anything, the installation hangs on 'pending' and never gets installed. Moreover, there seem to be no Network connection when updating currently installed applications using the last tab of the Ubuntu-Software center. I have been digging around for 2 weeks now and found nothing useful or any workarounds for it. Does anybody have the same or similar situation?

Best regards

0

You can use bleachbit to clean , and reboot the machine. That will get it back. I have the same issue, and this works for me. I have tried ubuntu tweak janitor, but it did not work for me getting the software centre to behave again. However, since I do not want to do this all the time, I use Gdebi and Synaptic to install what i need.

Hope this helps.

| improve this answer | |
  • I could try this, but i would not because puppet is running on the machine and there are a lot of configurations, packages, files that are puppet controlled and/or installed therefore using this method would be too risky. Thanks for the idea though. – foot3print Sep 29 '16 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.