61

This is my desktop, the icon is too big. enter image description here

I tried to use

gsettings set org.gnome.nautilus.desktop font "Ubuntu 9"

but the it changes only font size of the desktop icons.

I tried to use Compiz, Advance Settings and Configuration Editor but they just have font size option, not icon size option.

How to change the desktop icon size?

2
  • 8
    Go to Files (file manager app), Visualize the Desktop folder, Choose grid view in upper right corner of window, Resize the icons. Maybe, it's a solution.
    – user609611
    Oct 21 '16 at 2:04
  • In Ubuntu-MATE (thus Caja being the desktop manager) it's: Caja→Preferences→Views Tab→Icon View Defaults→Default zoom level. (and one can still do ctrl-+ to change sizing inside file explorer windows w/o affecting desktop icon size) Jun 21 at 6:25

16 Answers 16

73

I had the same problem because I had changed the icon size in a window. So I fixed it back from top-right of an open file browser window!

Changing icon size in any file browser window will affect all your windows including Desktop!

6
  • 2
    No kidding! Feeling the dummiest on earth ever! Feb 20 '17 at 13:19
  • 1
    more faster, in nautilus switch into icon view, then hold control + rotate mouse wheel!!! icons on a desktop will resize simultaneously )))) Sep 4 '18 at 16:39
  • The reason I didn't think this was the case was that I had the folder display view in "Details" view rather than the icon view and was only seeing the issue on the Desktop. Thanks! Jan 6 '19 at 15:16
  • I don't see that menu on the right when I click that middle icon.
    – Snowcrash
    Aug 2 '19 at 16:45
  • 1
    @Snowcrash in my case the option is in the right icon (the three lines icon) and it is a percent instead of a slider.
    – PhoneixS
    Aug 21 '19 at 5:48
29

Does this apply to all files put on the desktop or just the one icon you're showing? If the latter, that probably means you did it accidentally. Right click the icon, then select "Restore Icon's Original Size...".

The first one, I don't know (yet) how that would happen.

Also, maybe you could try gconf-editor. In it, go to apps>nautilus>icon_view. There's a setting for icon size there. Maybe that's what you need.

If you are using dconf-editor, the path to "icon_view" setting is org>gnome>nautilus>icon_view

4
  • 7
    I did it. I go to "Nautilus/Preferences/My Icon View Default", it zooms 400%. Changing it to 100% solved the problem. Thanks for the tips nautilus > icon_view. Nov 27 '11 at 7:04
  • 1
    I am not able to find nautilus after expanding the "apps" tree. Can you guide ?
    – zarpio
    Mar 19 '15 at 11:37
  • 2
    @zarpio This is because you're using the newer "dconf-editor." There's really very little reason to use this anymore for the same issue. There are better GUI fixes available like from the other answers. But if you must, since the editor controls offer more minutiae, the tree in the dconf Editor for nautilus has been moved to "org/gnome/nautilus."
    – kelvinilla
    Mar 20 '15 at 7:21
  • gconf-editor zsh: command not found: gconf-editor
    – Snowcrash
    Aug 2 '19 at 16:42
25
gsettings set org.gnome.nautilus.icon-view default-zoom-level 'small'
4
  • Thank god for one person who posts something that actually makes some sense.
    – Snowcrash
    Aug 2 '19 at 16:47
  • Perfect - this should have far more upvotes! I use Linux I don't want to fiddle with installing other software or tinkering with UIs to do this kind of thing! Apr 28 '20 at 19:59
  • This should be top answer.
    – Sam Murphy
    Jul 13 '20 at 10:33
  • Very useful working advice. Thank you very much. 'Top answer' indeed. Oct 27 '20 at 10:59
20
  1. Right click the icon you want to resize. Select "Resize icon..."

    Screenshot of mouse hovering over "Resize icon..." option in context menu.

  2. Hold-click and drag the handles that appear over the icon to resize it.

    Screenshot of mouse dragging icon handles to make icon larger.

You can revert to the icon's default size by selecting "Restore Icon's Original Size" in the icon's right-click context menu.

5
  • 1
    Wow, I just found out this. Really cool feature. Thanks for sharing :D
    – Mythul
    Mar 21 '15 at 14:18
  • it edit only one icon !!! wat will be if on desktop alot icons 100 ore more ???? Sep 4 '18 at 16:36
  • 1
    I loved this feature - its now missing on 19.04 Jan 14 '19 at 0:37
  • Definitely NOT the best answer here, but +1 for still being useful and good to know! Jun 14 '19 at 6:18
  • I don't see "Restore Icon's Original Size" in the icon's right-click context menu.
    – Snowcrash
    Aug 2 '19 at 16:46
20

Just open Nautilus. Go to EditPreferences and change the percentage of the Icon View Defaults (in German, Symbolansicht) (33%, 50%, 66%, 100%, 200%).

Why this setting affects the size of the icons on your desktop will be a mystery forever! But that is the easiest way to resize all icons on the desktop at once without using any tool like gconf-editor.

2
  • how to open nautilus ?
    – creative
    Jan 15 '17 at 7:05
  • 2
    @Hirak nautilus is the file manager. Open any directory, or look for Files in the Dash/Launcher
    – muru
    Feb 18 '17 at 5:27
5
  • open a folder (any folder)

  • go to menu -> preferences in the file explorer,

  • change default zoom level to 100%.

3

Max icon size

For desktop icons, there is a default size, which could be used as maximum size if you define smaller images than this value.

Using , this value is called: org.gnome.nautilus.icon-view thumbnail-size, but under , this value is called org.mate.caja.icon-view thumbnail-size.

You could show this by running command:

$ gsettings list-recursively | grep thumbnail-size
org.mate.caja.icon-view thumbnail-size 64
org.gnome.nautilus.icon-view thumbnail-size 64

and you can alter this by running:

$ gsettings set org.mate.caja.icon-view thumbnail-size 150

or

$ gsettings set org.gnome.nautilus.icon-view thumbnail-size 150

depending on wich desktop environment you're using.

Application

I use a little bash to render icons for my desktop like:

home.svg ( or with a bump filter: home.png )

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<svg version="1.0" xmlns="http://www.w3.org/2000/svg"
   xmlns:xlink="http://www.w3.org/1999/xlink"
   xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
   width="82px" height="82px" viewBox="-1 -1 23 23" id="dfPieSvg-HOME">
  <defs id="defs4">
    <style type="text/css"><![CDATA[
      text {
         font-style:   bold; font-size:      4px; text-align:   center;
         line-height:  100%; writing-mode: lr-tb; text-anchor:  middle;
         fill:      #ffffff; fill-opacity:    .7; stroke:       none;
         font-family:  Nimbus Sans L }
      text#t1 { font-size:    6px; }
      circle { fill:         #062; color:        black; fill-opacity: 1; }
      path { fill:         #800; fill-opacity: 1 }
    ]]></style>
  </defs>
  <g id="layer1">
    <circle id="gC" cx="10" cy="10" r="10" />
    <path id="rP" d="M 20,10 A 10,10 0 0 1 0.86473,14.06779 L 10,10 z" />
    <text x="10" y="12.2" id="t1"><tspan x="10" y="12.2">43.3%</tspan></text>
    <text x="10" y="16.7" id="t2"><tspan x="10" y="16.7">31.4G</tspan></text>
    <text x="10" y="7" id="t3"><tspan x="10" y="7">17.8G</tspan></text>
  </g>
</svg>

Of course, SVG width and SVG height (82px) is computed by my script, and stay smaller than 150.

You could find the full bash script there: dfpie.tgz

3

Simplest thing I did was to open file manager(nautilus). Then did a zoom-out using the (ctrl+mouse wheel) combo to decrease the icon size as I needed. By that, the desktop icons also got resized to the same icon size! Looks like the nautilus controls the icon size everywhere - desktop-view as well as the folder-view.

3

In ubuntu 21.04:

  1. run gnome-tweaks in terminal
  2. click extensions
  3. turn on Desktop icons ng (ding) (not Desktop icons)enter image description here
  4. Right click on the desktop -> settings
  5. Select size for desktop icons enter image description here
1

For others who may have the same question:

  1. Open 'files' (the graphical file explorer in ubuntu)
  2. edit > preferences
  3. under "icon view defaults" change "default zoom level" and see the effect on the items on your desktop.
1

If one opens Files and selects the display type (icons or lists) button, it allows one to change size with the slider. This affects the open window and everything that is on the desktop. I still have to re-arrange but main problem is fixed.

0
1

This solution works only for Ubuntu 20.04 with the GNOME Desktop installed, not unity.

For Ubuntu 20.04, you need to look for a GNOME Shell extension that manage the desktop icons. The extension "Desktop Icons" seems to be installed by default in some cases for that purpose. I assume you’re using it or maybe another one called "DING".

To know which is installed and active on your computer for Ubuntu 20.04 and more, just launch "Extensions" from Activities or open a terminal and type gnome-extensions-app. If you can’t find both of them, make sure the package gnome-shell-extension-prefs is installed.

This will open a new window where you can see informations about your gnome extensions and manage them.


Desktop Icons

If you see on the extensions window that Desktop Icons is enabled, click on its settings button. You can now select the icon size between small, standard and large.

If you want to customize even more and choose your own dimensions for those three options, see this answer for Ubuntu 20.04. Keep in mind that the extension’s directory name begins with desktop-icons@ and is usually either at :

  • /usr/share/gnome-shell/extensions if it’s been installed by the system (or apt…),
  • ~/.local/share/gnome-shell/extensions if it’s been exclusively installed by the user for his own personal use, generally through this website.

DING

If you’re using Desktop Icons NG (DING), right-click on your desktop and choose "Settings" (or something similar…). Now you can change the icon size to either tiny, small, standard or large.

If you want to customize even more and choose your own icon dimensions, go to the extension’s directory. Its name starts with ding@ and it’s usually at ~/.local/share/gnome-shell/extensions.

Now, in the ding@… directory, edit enums.js, lines 19 to 21 and set your own values:

var ICON_SIZE = { 'tiny': 36, 'small': 42, 'standard': 50, 'large': 66 };
var ICON_WIDTH = { 'tiny': 70, 'small': 80, 'standard': 95, 'large': 100 };
var ICON_HEIGHT = { 'tiny': 70, 'small': 80, 'standard': 88, 'large': 104 };

Finally, restart the gnome shell by hitting <ALT+F2> keys and typing r.


See also: How do I install and manage GNOME Shell extensions?

0

Right click on the Desktop - select 'Change Desktop Background' this brings up the 'Appearance' window, at the bottom is 'Launcher Icon Size' move the slider

1
  • 3
    -1 there is a difference between launcher icon and desktop icon Sep 1 '13 at 16:53
0

I managed to change the size of the icons by open a folder (any folder) with files inside (any type of files) and pressing Ctrl + Mouse Scroll, this change the size for all files inside and outside the folder.

0

Tested in Ubuntu 18.04 running the default Gnome desktop.

If using nemo as your file and desktop manager, simply right-click and go to Desktop --> Icon Size, as shown below. If you're not using nemo as your file and desktop manager, you should be. See the end of the answer linked-to above to see comparisons and screenshots to show the difference.

enter image description here

To find out why you'd want to use nemo as your file manager instead of Ubuntu's default nautilus, and to find out how to install it and set it up, see here: How to set Nemo as the default file manager in Ubuntu 18.04?.

0

With nautilus uninstalled, gnome desktop this extension worked for me. It has 3 settings for icon size. https://extensions.gnome.org/extension/2452/desktop-icons/ - settings from tweaks, settings for it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.