2

I can no longer get the HDMI port to work on my laptop (Asus TP300L) after a reboot earlier today. I can confirm that this is not a hardware issue as the external monitor works fine on win10 and another computer. I've tried connecting to my TV too which also fails with the same problem.

As far as I can tell, Ubuntu is no longer acknowledging that the system has an HDMI port.

Output from xrandr:

Screen 0: minimum 8 x 8, current 1366 x 768, maximum 32767 x 32767
eDP1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
   1366x768      59.97*+  39.98  
   1360x768      59.80    59.96  
   1280x720      60.00  
   1024x768      60.00  
   1024x576      60.00  
   960x540       60.00  
   800x600       60.32    56.25  
   864x486       60.00  
   640x480       59.94  
   720x405       60.00  
   680x384       60.00  
   640x360       60.00  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Graphics info from lspci:

00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Broadwell-U Integrated Graphics
    Flags: bus master, fast devsel, latency 0, IRQ 46
    Memory at f6000000 (64-bit, non-prefetchable) [size=16M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at f000 [size=64]
    Expansion ROM at  [disabled]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [a4] PCI Advanced Features
    Kernel driver in use: i915
    Kernel modules: i915

Thanks in advance for any assistance.

  • 1
    You didn't upgrade the kernel or anything, did you? – Android Dev Sep 28 '16 at 14:27
  • No, I only rebooted because the WiFi was refusing to connect (that at least is working now..!). I've tried different kernel versions via Grub->Advanced Options for Ubuntu with no difference – MidnightTortoise Sep 28 '16 at 14:33
  • 1
    Very strange indeed. – Android Dev Sep 28 '16 at 14:37
0

I never managed to find a solution to this, however it has automagically fixed itself after another update. Presumably a minor bug from the previous update now fixed, but we'll never know for certain =)

  • I now have same problem, all of the sudden. I wish it would fix itself like yours did. – pauljohn32 May 21 '17 at 3:00
  • Given that it took a fortnight for it to sort itself, I do hope you find a solution better than just waiting for it to fix itself! – MidnightTortoise May 21 '17 at 17:15
  • @pauljohn32 probably, you could try this solution? askubuntu.com/q/966883 – Yaksha Oct 24 '17 at 15:52
  • I replaced HDMI cable and problem was solved. I gather the connectors are not meant to be unplugged and replugged 2 times daily – pauljohn32 Oct 26 '17 at 4:12
0

I recently ran into this issue with Ubuntu 17.10 and 18.04, and Linux Mint 18.03 with my Dell Latitude E7470 Laptop. The kernel that worked to restore HDMI for me was 4.15.18-041518-generic. I installed it using the ukuu tool from https://launchpad.net/~teejee2008/+archive/ubuntu/ppa .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.