I use Ubuntu 16.04 LTS on my PC and I'm trying to connect my Samsung S6 device to this Ubuntu with USB on MTP Connection. I always get this popping up:

unable to mount Samsung Android

I can't even copy even an audio track. I'm developing Android apps and need to test on my device but I cannot get full connection between adb and my phone. I see my device name on the list but the same message pops up every 30 seconds.

enter image description here

I just took a screenshot. The shadows mean there are many instances of the same dialog under that! And it already opened many empty folders as you can see. This happened in just 1 or 2 mins.

What I have tried

  • I added attr to 51-android.rules and 69-libmtp.rules with lsusb results
  • installed libmtp-1.1.12 , gmtp , mtp-tools, go-mtpfs , gvfs , mtpfs
  • tried on both usb2.0 and usb3.0 port
  • tried with debug enabled and disabled
  • already selected MTP Connection type in USB Configuration under the Developer Options Menu in Android
  • 1
    Sometimes stray downvotes fly around, but it's best not to take them personally. Let's try to keep our own contributions to this site as constructive, friendly, and helpful as possible! – Nick Weinberg Sep 28 '16 at 12:33
  • I don't understand what you mean by "troubleshooting many times in a minute". (Maybe I don't understand your usage of "troubleshooting".) Would it be possible for you to clarify what you mean? Are you seeing any specific messages or errors on your screen? – Nick Weinberg Sep 28 '16 at 12:37
  • i just added a screen shot. it may helps to solve this problem :/ – erginduran Sep 28 '16 at 12:55
  • Have you updated /etc/udev/rules.d/51-android.rules ? – Organic Marble Sep 28 '16 at 14:38
  • When you say "Troubleshout" do you mean "Error Message"? To many of us it sounds like "troubleshooting" which has a completely different meaning. – Organic Marble Sep 28 '16 at 14:38

My Galaxy S4 will do the same thing on a 3.0 USB port. Try using a 2.0 USB port if you have one. You might also try a different USB cord. It shouldn’t make a difference, but it does. I got mine to work with a 3.0 port by swapping out cords until I found one that did the job.

  • check my solution list.i already tried usb2.0 and 3.0 ports on my laptop :/ i have 2x usb2 and 1x usb3 port and i tried on all ports but still same message pops up "unable to mount samsung android" – erginduran Sep 28 '16 at 21:53
  • 1
    Changing cord did the tricky for me! – Kees Schepers May 22 '17 at 21:45
  • I found a simlar situation with a Samsung tablet which requires its own cable to charge properly. I looked into it and have summarized my findings in this Android.se answer. – terdon Jun 7 '17 at 8:43
  • Dont think it need's it own cable but it is clear not all usb cables are the same. some seem to charge only! – Exile Jan 7 '18 at 14:21

I had the same problem. I'm using 16.04. I just had to install mtpfs. Run in terminal:

sudo apt-get install mtpfs

Thanks to this Stack Overflow answer!

  • It did the job! :-) – Ivo Mar 7 '17 at 18:44
  • It works here too, but strange we have to install something for just that simple task. thx – omisson Jul 10 '17 at 13:04

I was having similar problems - the phone would charge, but the computer (ubuntu 16.04) wasn't "seeing" it, i.e. it wasn't mounting.

For me, it didn't have anything to do with USB 2.0 or 3.0 or any of the MTP libraries. It was simply the USB cable. I've tested a bunch of different micro USB cables and have observed that with the cables that work, the pins inside the micro USB part are closer to the front than on cables that don't work.




Somebody broke VLC around Ubuntu 18.04. Fingers pointing at the other guys.

I don't have a direct solution but I do have a workaround that works every time.

Install the Disk Mount applet. This is a built-in widget that simply has to be activated. This applet displays on the top bar (Ubuntu mate 18.04 and beyond) the drives that are present and if a drive is clicked on, offers basic partition data.

Plug in your phone. Two icons will appear. One will do nothing. The other allows one to to do various things including "mount" Choose mount. In a few seconds, the phone will be mounted and a file manager window will appear.

Proceed as if an automatic file manager window had opened when the phone is plugged into the USB port.

Note: Be SURE to un-mount the drive before disconnecting the phone. Failing to do so leads to erratic behavior and generally requires a reboot.

Here is an alternative that I'd been using until I discovered the above method.


This is a clunky program but it does work.

Hope this helps. John


If you disabled the package with a disabler app search for MTP and enable it again. Takes a minute to turn back on, ask me how I know lol

  • 3
    Welcome to Ask Ubuntu! I'm not sure what exactly you're recommending. Therefore I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) – David Foerster Jan 20 '17 at 10:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.