3

mass : 1.9.3 juju: 1.25.5

When I try to deploy local charm it returns this error, the juju is working for non local charms like RabbitMQ.

It was working 3 month ago, I removed all local charms at that time, after 3 month I see this error:

When I tried to access that link on browser it returned:

An error occurred during a connection to node01.maas:17070. You have received an invalid certificate. 
Please contact the server administrator or email correspondent and give them the following information: 
Your certificate contains the same serial number as another certificate issued by the certificate authority. 
Please get a new certificate containing a unique serial number. Error code: SEC_ERROR_REUSED_ISSUER_AND_SERIAL

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

Here is the error:

  • 2016-09-28 00:55:07 INFO juju.cmd supercommand.go:37 running juju [1.25.5-wily-amd64 gc]
  • 2016-09-28 00:55:07 DEBUG juju.api api.go:154 trying cached API connection settings - endpoints [10.196.1.169:1707168.110.100:17070]
  • 2016-09-28 00:55:07 INFO juju.api api.go:266 connecting to API addresses: [10.196.1.169:17070 192.168.110.100:1707
  • 2016-09-28 00:55:07 INFO juju.api apiclient.go:262 dialing "wss://10.196.1.169:17070/environment/6f95c74a-a4ed-44a-e42fb59df71e/api"
  • 2016-09-28 00:55:07 INFO juju.api apiclient.go:194 connection established to "wss://10.196.1.169:17070/environment74a-a4ed-44a7-80b3-e42fb59df71e/api"
  • 2016-09-28 00:55:07 DEBUG juju.api api.go:476 API hostnames unchanged - not resolving
  • 2016-09-28 00:55:07 DEBUG juju.api api.go:506 cacheChangedAPIInfo: serverUUID="6f95c74a-a4ed-44a7-80b3-e42fb59df71
  • 2016-09-28 00:55:14 ERROR juju.cmd supercommand.go:429 cannot upload charm: Post https://10.196.1.169:17070/enviro6f95c74a-a4ed-44a7-80b3-e42fb59df71e/charms?series=trusty: Forbidden

Solution:

  • Destroy juju environment
  • Run sudo ssh-keygen -f "/root/.ssh/known_hosts" -R Node01.maas
  • bootstrap juju
  • This strikes me as a permissions error (you don't have access to the server), but it also seems your IP address is invalid (unless you blanked it out intentionally). I would be inclined to check any credentials for the service are valid, or to directly request support from juju. Doesn't really sound like an Ubuntu problem at all. – XtrmJosh Sep 28 '16 at 0:52
  • @Rastin can you post this as an answer instead of editing the question so we can mark it solved? Thanks! – Jorge Castro Sep 28 '16 at 23:27
  • I tried to post as answer, however the site suggested me to update the problem or comment !I will put the solution as answer!Thanks. – Rastin Sep 29 '16 at 17:27
1

It seems it was because of "ca-private-key" and "ca-cert" in maas.jenv! May be there is shorter solution in terms of time, if you have any idea please let me know.

Solution:

  1. Destroy juju environment
  2. Run sudo ssh-keygen -f "/root/.ssh/known_hosts" -R Node01.maas
  3. bootstrap juju again

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.