I am running Ubuntu 16.04 LTS, but I haven't been able to run it any more since the latest update. I saw a related question where a user named @Fairglow called this problem a "kernel regression". Indeed, I can still access the Operating System via the older Ubuntu, with Linux 4.4.0-38generic, but not through the more recent Ubuntu, with Linux 4.4.0-39generic. This doesn't come without problems, though.

As far as I know, there's also another question tackling a similar question, although with entirely a different problem (System update almost broke the system). That one, however, was marked as a duplicate of ALERT! /dev/disk/by-uuid/xxxxxxxxx does not exist. Dropping to a shell. But that post doesn't solve the problem.

What happened is that I followed the steps and the commands given:

  1. I created a LiveUSB for Ubuntu by using Startup Disc Creator
  2. I booted using this LiveUSB, choosing the Try Ubuntu option, as advised at ALERT! /dev/disk/by-uuid/xxxxxxxxx does not exist. Dropping to a shell
  3. I ran all the suggested commands

This is what happened:

$ sudo mount /dev/sda1 /mnt
mount: /dev/sda1 is write-protected, mounting read-only
mount: /dev/sda1 is already mounted or /mnt busy
$ sudo mount --bind /dev /mnt/dev
mount: mount point /mnt/dev does not exist
$ sudo mount --bind /proc /mnt/proc
mount: mount point /mnt/proc does not exist
$ sudo mount --bind /sys /mnt/sys
mount: mount point /mnt/sys does not exist
$ sudo chroot /mnt
chroot: failed to run command ‘/bin/bash’: No such file or     directory
$ update-initramfs -u
update-initramfs is disabled since running on read-only media
$ update-grub
grub-mkconfig: You must run this as root

Therefore, the answers did not help to solve the problem, unlike mistakenly said in the last thread. I've now tried this suggestion, but it seems I am not even able to write on the disc. Any ideas how to fix this? :-(

  • Look at the output from the commands. They all gave errors. – Android Dev Sep 27 '16 at 18:00
  • @Android Dev I know, therefore I think it's absurd that the thread was closed even though the advises given there clearly don't solve the problem. I was hoping to know, though, why I get this error messages likemount: /dev/sda1 is write-protected, mounting read-only, or why I'm being told that the files / folders do not exist. Apparently, the instructions given to justify to close the discussion do not work. :-P – Jayaguru-Shishya Sep 28 '16 at 12:45
  • FYI - AskUbuntu is not a forum. It is a Q&A site. We have questions, not threads :) As to it being an improper dupe, you can enter the chat.stackexchange.com/rooms/201/ask-ubuntu-general-room chatroom, where there a lots of high-rep users like myself, who are able to re-open questions. If you explain why it isn't a dupe there, they might decide to re-open it. – Android Dev Sep 28 '16 at 13:27
  • @AndroidDev I know, that's why I asked a specific question concerning the problem that I am experiencing ;-) There's already on answer below where I am asking for more specific instructions – Jayaguru-Shishya Sep 28 '16 at 17:22

become root but running su , create these mount points like: mkdir -p /mnt/proc and try again, just make sure you are root, it sounds whole a little too difficult.

i believe grub update should be sufficient. look for: restoring grub after windows update if you need to reinstall grub loader too. otherwise just update grub with boot directory option

  • Thanks for your answer! Sorry, I am rather a noob on Linux, although I made the "leap of faith" directly from Windows to Linux, and there is no way going back (i.e. I am running a laptop only equipped with Linux right now)! Anyway, could you please provide a more step-by-step instructions? :-) Like; 1) what commands should I run through the terminal (I am still studying the whole process process and the logic), 2) what mount points should I create and how (sorry, I don't even know what a mount point is), and 3) how about the GRUB update, how to carry that out? :-P Thanks Galvani! – Jayaguru-Shishya Sep 28 '16 at 12:51

Well, if it is just one image failing, and you are able to boot into the system using older kernel. You definitely should do that. Upgrade the kernel once more, current version is 4.4.0-21, verify all sources are available by updating

sudo apt-get update

Attempt to upgrade all necessary

sudo apt-get dist-upgrade

and try again, I would suggest not using the kernel, unless you really need to. If you do, try the new version.

What would really help is a log or posting here some errors you get. Describe the trouble better.

Anyways; as far as I understand it; your system is fine. It's just one kernel failing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.