2

I've seen this question and tried the answer at the bottom of the page yesterday and it seemed to work. But then I woke up today and had the same DNS_PROBE_FINISHED_BAD_CONFIG error for like over an hour. So then I tried that solution at the bottom again and it seems to have worked but just in case I created an account and am making this question. I also tried the answer with 26 likes but ran into a problem. I pasted sudo rm /etc/resolv.conf to my terminal and after typing in my password nothing happened.

EDIT: The error happened again as I was trying to post this. I am now using a wired connection.

enp3s0    Link encap:Ethernet  HWaddr 00:26:2d:ad:4e:4c  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:2650 errors:0 dropped:0 overruns:0 frame:0
      TX packets:3087 errors:0 dropped:0 overruns:0 carrier:2
      collisions:0 txqueuelen:1000 
      RX bytes:1617267 (1.6 MB)  TX bytes:581129 (581.1 KB)

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:11404 errors:0 dropped:0 overruns:0 frame:0
      TX packets:11404 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1 
      RX bytes:907993 (907.9 KB)  TX bytes:907993 (907.9 KB)

wlp6s0    Link encap:Ethernet  HWaddr 78:e4:00:eb:df:96  
      inet addr:192.168.0.20  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::b01:f3f0:11f8:cedd/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:41203 errors:0 dropped:0 overruns:0 frame:0
      TX packets:30797 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:39196701 (39.1 MB)  TX bytes:6166586 (6.1 MB)

When I pasted ls /run/resolvconf/interface/ in the terminal I got NetworkManager.

EDIT from comments: I have a modem from ubee, it's DDW365

Everything from "127.0.0.1 localhost" to "ff02::2 ip6-allrouters" was what was within my hosts file.

127.0.0.1   localhost

127.0.1.1   aaron-Aspire-One-721

#The following lines are desirable for IPv6 capable hosts

::1     ip6-localhost ip6-loopback

fe00::0 ip6-localnet

ff00::0 ip6-mcastprefix

ff02::1 ip6-allnodes

ff02::2 ip6-allrouters

This is from my host.conf file:

 # The "order" line is only used by old versions of the C library.
    order hosts,bind
    multi on

None of my DNS match the DNS here.

My WAN

IPv4 DNS Servers:   68.105.28.11
        68.105.29.11
        68.105.28.12

Output of nmcli device show

GENERAL.DEVICE:                         wlp6s0
GENERAL.TYPE:                           wifi
GENERAL.HWADDR:                         78:E4:00:EB:DF:96
GENERAL.MTU:                            0
GENERAL.STATE:                          100 (connected)
GENERAL.CONNECTION:                     DDW365.51939A-2.4G
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/8
IP4.ADDRESS[1]:                         192.168.0.20/24
IP4.GATEWAY:                            192.168.0.1
IP4.ROUTE[1]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             68.105.28.11
IP4.DNS[2]:                             68.105.29.11
IP4.DNS[3]:                             68.105.28.12
IP6.ADDRESS[1]:                         fe80::b01:f3f0:11f8:cedd/64
IP6.GATEWAY:                            

GENERAL.DEVICE:                         enp3s0
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         00:26:2D:AD:4E:4C
GENERAL.MTU:                            1500
GENERAL.STATE:                          20 (unavailable)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
WIRED-PROPERTIES.CARRIER:               off

GENERAL.DEVICE:                         lo
GENERAL.TYPE:                           loopback
GENERAL.HWADDR:                         00:00:00:00:00:00
GENERAL.MTU:                            65536
GENERAL.STATE:                          10 (unmanaged)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.ADDRESS[1]:                         127.0.0.1/8
IP4.GATEWAY:                            
IP6.ADDRESS[1]:                         ::1/12

closed as off-topic by Elder Geek, waltinator, David Foerster, Aaron, andrew.46 Oct 7 '16 at 21:35

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Elder Geek, waltinator, David Foerster, Aaron, andrew.46
If this question can be reworded to fit the rules in the help center, please edit the question.

  • It says Automatic as method. The Address box is also blanked out. – BlackTunicLink Sep 27 '16 at 22:18
  • And I have a hosts file and a host.conf file. So I misread when I said I had two earlier. – BlackTunicLink Sep 27 '16 at 22:25
4

Try

sudo dhclient -r interfacename
sudo dhclient interfacename

where interfacename is yours (mine is eth0)

This will release and renew your Ip address.

If this doesn't help, The COX DNS servers you are using may be overloaded. This is especially likely if this is an intermittent problem.

Google Public DNS operates recursive name servers for public use at the following IP addresses: 8.8.8.8 and 8.8.4.4 for IPv4 service, as well as 2001:4860:4860::8888 and 2001:4860:4860::8844, for IPv6 access. The addresses are mapped to the nearest operational server by anycast routing. I suggest you try those and see if you get better results.

I've found 8.8.8.8 to be very responsive. Open Network Connections and edit your entries as shown below. Then Click Save. This should resolve the issue.

EditDNS

  • I already have that stuff saved to my hosts file. I'll enter that command in the terminal. – BlackTunicLink Sep 27 '16 at 22:20
  • I did everthing you asked me. – BlackTunicLink Sep 28 '16 at 2:31
  • How do I find my network interface name? I just noticed that you edited your post. Also, this problem is intermittent. I've never had this happen before until now. – BlackTunicLink Sep 28 '16 at 16:23
  • nmcli device show will give details on both the wired and wireless and it will be clear which is which. See my answer in regards to intermittent DNS problems. (I.E. Change DNS settings) – Elder Geek Sep 28 '16 at 16:24
  • This is what I get when I type that. i.imgur.com/LTY1l0b.png I used the text with DDW365 in it but it was apparently too long. – BlackTunicLink Sep 28 '16 at 17:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.