4

I was installing mininet on my ubuntu 14.04.3 and during the installation, I got the error "ImportError : No module named setuptools". I tried to install it using sudo apt-get install python-setuptools and it shows that it is already the newest version. But still the installation fails.

For installing mininet I followed the steps on https://github.com/mininet/mininet/blob/master/INSTALL and tried the following commands

git clone git://github.com/mininet/mininet.git
 cd mininet
 git tag
 git checkout 2.2.1
 util/install.sh -n

then the installation ran and stopped in between showing the error.

5
  • 1
    And how were you installing mininet?
    – edwinksl
    Sep 27 '16 at 13:12
  • from installation instructions in the mininet github page Sep 27 '16 at 13:13
  • There are 4 options there. Which one did you pick? Please be specific.
    – edwinksl
    Sep 27 '16 at 13:14
  • native installation from source - the third option Sep 27 '16 at 13:15
  • 2
    It would be preferable if you edit your question and add the exact steps you followed instead of letting us look it up.
    – Byte Commander
    Sep 27 '16 at 13:19
6

Use this command to install necessary package

sudo apt-get install python3-setuptools

If the application is python2 use this instead

sudo apt-get install python-setuptools
11
  • I did it and still I am getting the error during the installation. Sep 27 '16 at 13:43
  • Did you install python3-setuptools also?
    – Anwar
    Sep 27 '16 at 13:46
  • I did not install python3-setuptools as I am having only python 2.7.5 Sep 27 '16 at 13:49
  • install Python3-setuptools
    – Anwar
    Sep 27 '16 at 13:50
  • Okay. Will that create any problem on my machine as other softwares on my machine require only python 2.7.5? Sep 27 '16 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.