1

This question already has an answer here:

Here is a report when I run boot-repair off a live-usb http://paste2.org/dtAWjmMU

So at this point I can either:

A. Set my booting priority in BIOS to my SSD with Ubuntu 16.04, get the grub2 menu but no option to boot into Windows 10 but two memtest86+ options.

or

B. Set my booting priority in BIOS to Windows Bootloader (the SSD with Windows 10), the computer starts up Windows 10 and grub2 doesn't show up at all.

How do I go about dual booting so that I can boot from my Ubuntu 16.04 drive -> grub2 and have the option to select which OS I want to boot from?

On a side note, is there a significance after this process is done for the memtest86+ options?

I've honestly tried a bunch of links but if there is one I missed that addresses this particular case please direct me.

Thank you

EDIT: A user posted a link to this question:

GRUB does not detect Windows

and after following those steps now I end up with no grub2 menu at all upon startup. Will edit further after I run boot-repair.

EDIT: After booting from live-usb and running boot-repair this is my report:

http://paste2.org/wx0jNMNI

So the original problem has now changed to not being able to boot into grub2 at all. Please don't direct me to more links that don't answer my question and make my problem worse.

marked as duplicate by Rinzwind, Zanna, TheWanderer, Aaron, Eric Carvalho Sep 28 '16 at 23:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Now after completing the steps in that question...I don't go into grub2 anymore upon startup. – ASwiftPeregrine Sep 27 '16 at 18:24
  • @ASwiftPeregrine: What do you mean? Is the boot process stalled before you see the Grub menu or does it just skip over the boot menu and boot one operating system? By the way, Boot-Repair found one Windows installation and claims to have fixed the boot loader. – David Foerster Sep 28 '16 at 8:13
1

Your fstab-file on sdb1 clearly shows that Ubuntu is installed in legacy-mode.

# /etc/fstab: static file system information.
#
/dev/mapper/ubuntu--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=e622e0fb-2c28-46f6-83f3-e5a638dbadf3 /boot           ext2    defaults        0       2
#/dev/mapper/ubuntu--vg-swap_1 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

Your drive sdb has MBR (dos-partition-table).

Windows is installed on sda in UEFI-mode. sda has GPT-partition-table.

You should convert drive sdb where Ubuntu is installed from MBR to GTP. To convert the drive from MBR to GPT boot the installer and choose Try Ubuntu without installing. Open terminal(Ctrl+Alt+T) and run command sudo gdisk sdb.

Upon start, gdisk attempts to identify the partition type in use on the disk.
If it finds valid GPT data, gdisk will use it. If gdisk finds a valid MBR but
no GPT data, it will attempt to  convert the  MBR  into GPT form. Upon
exiting  with  the  'w'  option,  gdisk replaces the MBR or disklabel with a GPT.
If you mistakenly launch gdisk on an MBR disk, you can safely  exit  the
program  without making any changes by using the 'q' option.

The MBR-to-GPT conversion will leave at least one gap in the  partition
numbering  if  the original MBR used logical partitions. These gaps are
harmless, but you can eliminate them by using the 's'  option,  if  you
like.

Then reinstall Ubuntu in UEFI-mode. To install in UEFI-mode you have to boot the installer in UEFI-mode, how you boot is how it installs.

You may create ESP (EFI System Partition, 500MB, FAT32, boot-flag) on sdb during install, but Grub will be installed on ESP of sda automatically.

  • If you type w at this point and hit enter, partition-taple will change to GPT – mook765 Sep 27 '16 at 19:57
  • Now after booting into the live-usb in UEFI mode I go to try Ubuntu and double click install shortcut on Desktop. I select Installation type as Something else. A message pops up asking if it wants me to dismount the sbc (usb drive I'm in). No or Yes? – ASwiftPeregrine Sep 28 '16 at 0:05
  • I would say No – mook765 Sep 28 '16 at 0:15
  • imgur.com/gallery/WAOuC – ASwiftPeregrine Sep 28 '16 at 0:18
  • Keep in mind sda is Windows SSD and sdb is Ubuntu SSD – ASwiftPeregrine Sep 28 '16 at 0:23
0

Choose windows as your default. If you want to boot into Ubuntu press esc after you power on your PC. This will give you a list of options to boot into. (somePC's require you to press F9 after pressing Esc)

  • I appreciate the idea. I would really like to boot into grub2 though and select which OS to start from without having to "time" an esc press. – ASwiftPeregrine Sep 27 '16 at 18:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.